HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   SpamAssassin stops working (http://www.howtoforge.com/forums/showthread.php?t=4527)

heygazeebo 27th May 2006 00:49

SpamAssassin stops working
 
Hi Everyone,

I followed falko's guide to setting up postfix / mysql etc. on debian, and then followed the guide to add mailfiltering to it. After just a bit of tinkering it mostly worked properly, until i noticed that at some point SpamAssassin had stopped scanning my emails. As best i can figure it was when i added in the mailfiltering portion of the setup. Virus detection is still working, but not Spam. Anybody have any suggestions?

falko 27th May 2006 14:57

Are there any errors in your log files?

heygazeebo 28th May 2006 06:40

No, the only mention i see of anything related to spam in the log files is when it tagged somthing as spam.

It does say this when i start amavisd...

Quote:

May 28 03:24:11 localhost amavis[16093]: Module Mail::SpamAssassin 3.000003
It says that among the list of modules....

I checked syslog and mail.log and mail.err, the only error i am seeing is this one:

Quote:

localhost dccproc[16115]: socket(UDP): Address family not supported by protocol
Im not sure what that one means though..

Thanks,

falko 28th May 2006 23:35

You could try to update to the latest SpamAssassin version. Hopefully that solves the problem...

heygazeebo 30th May 2006 06:10

Can you tell me how to find out what version of spamassassin i am running?

I did this:
Code:

/usr/bin/spamassassin -V
SpamAssassin version 3.0.3
  running on Perl version 5.8.4

But i do not think that is the correct?

I did apt-get upgrade spamassassin and it upgraded a lot of stuff, but that version stayed the same

Code:

apt-get upgrade spamassassin
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be upgraded:
  libmysqlclient12 lynx mysql-client mysql-common mysql-server postfix
  postfix-mysql postfix-tls
8 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I am seeing this in my headers to my email, but nothing to mention Spam anymore..

Code:

X-Virus-Scanned: by amavisd-new-20030616-p10 (Debian) at localhost

falko 30th May 2006 17:01

Quote:

Originally Posted by heygazeebo
Can you tell me how to find out what version of spamassassin i am running?

I did this:
Code:

/usr/bin/spamassassin -V
SpamAssassin version 3.0.3
  running on Perl version 5.8.4

But i do not think that is the correct?

That is the correct way to find out. :)

Quote:

I did apt-get upgrade spamassassin and it upgraded a lot of stuff, but that version stayed the same
The packages are not always up to date. If you want the newest version, you must compile it yourself.

heygazeebo 3rd June 2006 16:00

nope..
 
Code:

Jun  3 12:46:58 localhost amavis[778]: Module Mail::SpamAssassin  3.001002

Code:

/usr/bin/spamassassin -V
SpamAssassin version 3.1.2
  running on Perl version 5.8.4

Upgrading to the new version doesnt seem to have done the trick, it does not seem to be invoking spamassassin and doing the scanning anymore. Any other suggestions? Everything else is working perfectly!

falko 3rd June 2006 23:27

Did you maybe change /etc/amavisd.conf before it stopped working?

heygazeebo 4th June 2006 18:32

uhmm..
 
I do not seem to have an /etc/amavisd.conf file.. i have an /etc/amavisd/amavisd.conf file though.... could that be part of the problem?

falko 5th June 2006 15:33

Sorry, I meant /etc/amavis/amavisd.conf... Did you change that one recently?


All times are GMT +2. The time now is 10:39.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.