HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   MySQL Database Replication - can't upgrade (http://www.howtoforge.com/forums/showthread.php?t=44808)

kpm 11th April 2010 20:34

MySQL Database Replication - can't upgrade
 
Hi, some time ago, I set up two vps servers, one hosts web sites, the other for backup. I used Falco's great How To about mysql replication (http://www.howtoforge.com/mysql_database_replication) and the AutoMySQLBackup script for backing the live server up.
Both servers were running Ubuntu 8.10. I recently upgraded the web server from 8.10 to 9.04 then finally to 9.10. All went well with the exception of it taking me a while to find out I had to comment out "skip-bdb" on my.cnf to get MySQL up and running again.
However, I am now attempting to do the same with the backup vps but MySQL refuses to shut down. The results and error I get in the term after issuing an 'apt-get upgrade' command is:
Code:

Reading package lists... Done
Building dependency tree     
Reading state information... Done
The following packages will be upgraded:
  apache2 apache2-mpm-prefork apache2-utils apache2.2-common dhcp3-client
  dhcp3-common libapache2-mod-php5 libcups2 libcupsimage2 libexpat1 libkrb53
  libpng12-0 libpq5 libssl0.9.8 libthai-data libthai0 mysql-server mysql-server-5.0
  openssl php5 php5-cli php5-common php5-curl php5-gd php5-mysql python2.5
  python2.5-minimal sudo tzdata
29 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0B/43.9MB of archives.
After this operation, 53.2kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
(Reading database ... 18393 files and directories currently installed.)
Preparing to replace mysql-server 5.0.67-0ubuntu6 (using .../mysql-server_5.0.67-0ubuntu6.1_all.deb) ...
 * Stopping MySQL database server mysqld
  ...fail!
invoke-rc.d: initscript mysql, action "stop" failed.
invoke-rc.d returned 1
There is a MySQL server running, but we failed in our attempts to stop it.
Stop it yourself and try again!
dpkg: error processing /var/cache/apt/archives/mysql-server_5.0.67-0ubuntu6.1_all.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/mysql-server_5.0.67-0ubuntu6.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can someone point me in the right direction?
Thanks

falko 12th April 2010 14:04

Can you stop it manually...
Code:

/etc/init.d/mysql stop
... and try again?

kpm 12th April 2010 19:23

I tried to manually stop MySQL...
 
but I got the same error...

falko 13th April 2010 16:51

Please run
Code:

killall mysql
and try again.

kpm 14th April 2010 06:15

killall mysql returns...
 
"no process killed"

and attempting to stop afterward and or run upgrade again, returns the same error.

falko 15th April 2010 14:46

Can you find out the PIDs of the MySQL processes with
Code:

ps aux
and then kill the processes like this:
Code:

kill -9 PID

kpm 18th April 2010 03:54

thanks Falko
 
that did it.

All were killed, a mysqld process needed the extra -9 kick.

Now both servers are upgraded and humming along again.

Cheers


All times are GMT +2. The time now is 15:40.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.