HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Debootstrap method fails to get release file http://ftp.us.debian.org/debian/ (http://www.howtoforge.com/forums/showthread.php?t=44733)

vtapas 8th April 2010 08:57

Debootstrap method fails to get release file http://ftp.us.debian.org/debian/
 
This is the article I am referring to
http://www.howtoforge.com/using-xen-...ms-debian-etch

I try to install by debootstrap method and installation aborts in
middle of the process. The error showing in /var/log/xen-tools/filename.log is
Code:

I: Retrieving Release
E: Failed getting release file http://ftp.us.debian.org/debian/dists/lenny/Release

Copying files from new installation to host.
Copying files from /tmp/jUrDxM_Km2/var/cache/apt/archives -> /var/cache/apt/archives
Done
Done
The installation of the new system has failed.

The system is missing the common file: /bin/ls
Done
System installation failed.  Aborting

While I checked from browser link
http://ftp.us.debian.org/debian/dists/lenny/Release I was able to get
release file but some how debootstrap method is failing to get release
file what can be cause of error?

Mark_NL 8th April 2010 09:55

I know the url works when you wget it, but try a different mirror and try again, see what happens. I've had this problem as wel before, just switched mirrors and it worked for me.

vtapas 8th April 2010 10:55

Quote:

Originally Posted by Mark_NL (Post 224461)
I know the url works when you wget it, but try a different mirror and try again, see what happens. I've had this problem as wel before, just switched mirrors and it worked for me.

Yes that URL works that is why I mentioned above that RELEASE files I have been able to access from some other machine using a browser can you tell me how can I check if it is communicating with internet the machine is behind a proxy and ping www.google.com wont work behind a proxy.I have to do it on command line.

apt-get update is also having following problems so I guess that it
is some other issue.
Code:

openworld:~# apt-get update
Err http://http.us.debian.org stable Release.gpg                                                                                           
  Could not resolve 'http.us.debian.org'
Err http://http.us.debian.org stable/main Translation-en_US                                                                                 
  Could not resolve 'http.us.debian.org'
Err http://http.us.debian.org stable/contrib Translation-en_US                                           
  Could not resolve 'http.us.debian.org'
Err http://http.us.debian.org stable/non-free Translation-en_US                                         
  Could not resolve 'http.us.debian.org'
Err http://ftp.de.debian.org squeeze Release.gpg                                                         
  Could not resolve 'ftp.de.debian.org'
Err http://ftp.de.debian.org squeeze/main Translation-en_US                                             
  Could not resolve 'ftp.de.debian.org'
Err http://ftp.us.debian.org lenny Release.gpg                         
  Could not resolve 'ftp.us.debian.org'
Err http://ftp.us.debian.org lenny/main Translation-en_US             
  Could not resolve 'ftp.us.debian.org'
Err http://http.us.debian.org unstable Release.gpg
  Could not resolve 'http.us.debian.org'
Err http://http.us.debian.org unstable/main Translation-en_US
  Could not resolve 'http.us.debian.org'
Err http://security.debian.org etch/updates Release.gpg
  Could not resolve 'security.debian.org'
Err http://security.debian.org etch/updates/lenny Translation-en_US
  Could not resolve 'security.debian.org'
Err http://ftp.us.debian.org lenny/non-free Translation-en_US
  Could not resolve 'ftp.us.debian.org'
Err http://ftp.us.debian.org lenny/contrib Translation-en_US
  Could not resolve 'ftp.us.debian.org'
Err http://security.debian.org etch/updates/contrib Translation-en_US
  Could not resolve 'security.debian.org'
Err http://security.debian.org etch/updates/non-free Translation-en_US
  Could not resolve 'security.debian.org'
Err http://security.debian.org lenny/updates Release.gpg
  Could not resolve 'security.debian.org'
Err http://security.debian.org lenny/updates/main Translation-en_US
  Could not resolve 'security.debian.org'
Err http://security.debian.org stable/updates Release.gpg
  Could not resolve 'security.debian.org'
Err http://security.debian.org stable/updates/main Translation-en_US
  Could not resolve 'security.debian.org'
Err http://security.debian.org stable/updates/contrib Translation-en_US
  Could not resolve 'security.debian.org'
Err http://security.debian.org stable/updates/non-free Translation-en_US
  Could not resolve 'security.debian.org'
Err http://http.us.debian.org unstable/contrib Translation-en_US
  Could not resolve 'http.us.debian.org'
Err http://http.us.debian.org unstable/non-free Translation-en_US
  Could not resolve 'http.us.debian.org'
Reading package lists... Done
W: Failed to fetch http://ftp.us.debian.org/debian/dists/lenny/Release.gpg  Could not resolve 'ftp.us.debian.org'

W: Failed to fetch http://ftp.us.debian.org/debian/dists/lenny/main/i18n/Translation-en_US.bz2  Could not resolve 'ftp.us.debian.org'

W: Failed to fetch http://ftp.us.debian.org/debian/dists/lenny/non-free/i18n/Translation-en_US.bz2  Could not resolve 'ftp.us.debian.org'

W: Failed to fetch http://ftp.us.debian.org/debian/dists/lenny/contrib/i18n/Translation-en_US.bz2  Could not resolve 'ftp.us.debian.org'

W: Failed to fetch http://security.debian.org/dists/etch/updates/Release.gpg  Could not resolve 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/etch/updates/lenny/i18n/Translation-en_US.bz2  Could not resolve 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/etch/updates/contrib/i18n/Translation-en_US.bz2  Could not resolve 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/etch/updates/non-free/i18n/Translation-en_US.bz2  Could not resolve 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/lenny/updates/Release.gpg  Could not resolve 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/lenny/updates/main/i18n/Translation-en_US.bz2  Could not resolve 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/stable/updates/Release.gpg  Could not resolve 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/stable/updates/main/i18n/Translation-en_US.bz2  Could not resolve 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/stable/updates/contrib/i18n/Translation-en_US.bz2  Could not resolve 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/stable/updates/non-free/i18n/Translation-en_US.bz2  Could not resolve 'security.debian.org'

W: Failed to fetch http://http.us.debian.org/debian/dists/stable/Release.gpg  Could not resolve 'http.us.debian.org'

W: Failed to fetch http://http.us.debian.org/debian/dists/stable/main/i18n/Translation-en_US.bz2  Could not resolve 'http.us.debian.org'

W: Failed to fetch http://http.us.debian.org/debian/dists/stable/contrib/i18n/Translation-en_US.bz2  Could not resolve 'http.us.debian.org'

W: Failed to fetch http://http.us.debian.org/debian/dists/stable/non-free/i18n/Translation-en_US.bz2  Could not resolve 'http.us.debian.org'

W: Failed to fetch http://http.us.debian.org/debian/dists/unstable/Release.gpg  Could not resolve 'http.us.debian.org'

W: Failed to fetch http://http.us.debian.org/debian/dists/unstable/main/i18n/Translation-en_US.bz2  Could not resolve 'http.us.debian.org'

W: Failed to fetch http://http.us.debian.org/debian/dists/unstable/contrib/i18n/Translation-en_US.bz2  Could not resolve 'http.us.debian.org'

W: Failed to fetch http://http.us.debian.org/debian/dists/unstable/non-free/i18n/Translation-en_US.bz2  Could not resolve 'http.us.debian.org'

W: Failed to fetch http://ftp.de.debian.org/debian/dists/squeeze/Release.gpg  Could not resolve 'ftp.de.debian.org'

W: Failed to fetch http://ftp.de.debian.org/debian/dists/squeeze/main/i18n/Translation-en_US.bz2  Could not resolve 'ftp.de.debian.org'

W: Some index files failed to download, they have been ignored, or old ones used instead.
W: You may want to run apt-get update to correct these problems

I do not have a physical access to the machine.Only an ssh on LAN.

Mark_NL 8th April 2010 11:40

Code:

host ftp.us.debian.org
check if you get an ip response

if not, then you should check your nameserver settings (/etc/resolv.conf)

vtapas 8th April 2010 11:59

Yes It is giving an IP response so that means it is able to get to ftp.us.debian.org
So what should be next step.

Mark_NL 8th April 2010 13:14

Strange, because you said:

Code:

Err http://http.us.debian.org stable Release.gpg                                                                                           
  Could not resolve 'ftp.us.debian.org'

before, but it resolves just fine ..

what if you put this in your /etc/apt/sources.list:
Code:

deb http://ftp.nl.debian.org/debian/ lenny main
deb-src http://ftp.nl.debian.org/debian/ lenny main

deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib


vtapas 8th April 2010 13:51

Quote:

Originally Posted by Mark_NL (Post 224507)
Strange, because you said:

Code:

Err http://http.us.debian.org stable Release.gpg                                                                                           
  Could not resolve 'ftp.us.debian.org'

before, but it resolves just fine ..

what if you put this in your /etc/apt/sources.list:
Code:

deb http://ftp.nl.debian.org/debian/ lenny main
deb-src http://ftp.nl.debian.org/debian/ lenny main

deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib


By the time I read your reply I had transferred an Installation ISO to the target machine and loop mounted it.After wards gave the path to mounted folder where the installation CD was mounted
as following
Code:

openworld:~# xen-create-image --hostname=vignettes --size=150Gb --swap=4Gb --ip=192.168.100.151 --force --memory=2Gb --arch=amd64 --role=udev --install-method=debootstrap --install-source=/home/openworld/inscd/

General Information
--------------------
Hostname      :  vignettes
Distribution  :  lenny
Partitions    :  swap            4Gb  (swap)
                  /              150Gb (ext3)
Image type    :  full
Memory size    :  2Gb
Kernel path    :  /boot/vmlinuz-2.6.26-2-xen-amd64
Initrd path    :  /boot/initrd.img-2.6.26-2-xen-amd64

Networking Information
----------------------
IP Address 1  : 192.168.100.151 [MAC: 00:16:3E:0B:3A:9B]
Netmask        : 255.255.255.0
Broadcast      : 172.21.100.255
Gateway        : 192.168.100.147

Removing /dev/virtualization/vignettes-swap - since we're forcing the install
Removing /dev/virtualization/vignettes-disk - since we're forcing the install

Creating swap on /dev/virtualization/vignettes-swap
Done

Creating ext3 filesystem on /dev/virtualization/vignettes-disk
Done
Installation method: debootstrap
(Source: /home/openworld/inscd/)
Done

Running hooks
Done

Role: udev
        File: /etc/xen-tools/role.d/udev
Role script completed.

Creating Xen configuration file
Done
Setting up root password
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
All done

So I infer that installation was successful.
But I have to
Q1) Do a xend start each time I reboot Dom0 I want to get rid of this.
Q2) DomU did not booted
I tried xm console dom name it gave me an error dom does not exist but the process did not stop in between so why is that error coming I am not able to boot DomU .
I do
xm start vignettes
I get error
Code:

WARING!  Can't find version 3.2 of xen utils, fallback to default version!
Error: Domain 'vignettes' does not exist.

There is a corresponding cfg file in /etc/xen so I am not clear with what is the cause of error ?
How can I get rid of this one?

Mark_NL 8th April 2010 14:04

You should have a config file with the name of the dom0 in /etc/xen

f.e. /etc/xen/vignettes

vtapas 8th April 2010 14:21

Yes there is a config file
/etc/xen/vignettes.cfg

It fails to start domU
Code:

openworld:/etc/xen# xm start vignettes
WARING!  Can't find version 3.2 of xen utils, fallback to default version!
Error: Domain 'vignettes' does not exist.

What should be my next step?

Mark_NL 8th April 2010 14:46

Code:

apt-get install xen-utils-3.2-1
xm create vignettes.cfg



All times are GMT +2. The time now is 17:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.