HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Wordpress "ERROR 500-Internal..." on Debian Lenny ISPC3 (http://www.howtoforge.com/forums/showthread.php?t=44691)

KZeeSoft 6th April 2010 18:01

Wordpress "ERROR 500-Internal..." on Debian Lenny ISPC3
 
Hello everyone =)

Been trying to play around with WordPress for about a week now and have had some serious issues getting it to install.

I have tried:

- downloading the tar.gz file and manually installing it using PHPMYADMIN and configuring the wp_config.php file

- using apt-get install wordpress, then moving files and configuring from that point.


I always get the same error, "ERROR 500 - Internal Server Error"

- I have ensured that the Database username and password was correct (did it 10 times between different setups to ensure this).
- I have ensured PHP was enabled on the site I am installing it on.
- I have tried creating the database in ISPC3 control panel, and using PHPMYADMIN for privileges etc...
- When I look into the subdirectory of my site that has the Wordpress files (www.mydomain.com/forums) i get the same error, but when I place a txt file in that folder, i can access it from the web with no problem.


Any ideas?

I will post any log that you request.


Thanks in advance for the help!

falko 7th April 2010 16:09

Any errors in Apache's error log?

KZeeSoft 8th April 2010 04:20

Here is the Apache log file found at /var/log/apache2/error.log

Code:

Sun Apr 04 06:25:03 2010] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny8 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resu$
[Sun Apr 04 06:25:03 2010] [warn] long lost child came home! (pid 17905)
[Sun Apr 04 21:30:19 2010] [error] [client 192.168.1.2] File does not exist: /var/www/favicon.ico
[Mon Apr 05 02:38:08 2010] [error] [client 88.80.10.1] File does not exist: /usr/local/ispconfig/interface/web/pp
[Mon Apr 05 06:53:49 2010] [error] [client 143.166.226.58] client denied by server configuration: /htdocs
[Mon Apr 05 18:04:01 2010] [notice] Graceful restart requested, doing restart
[Mon Apr 05 18:04:02 2010] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny8 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resu$
[Mon Apr 05 18:04:02 2010] [warn] long lost child came home! (pid 5720)
[Mon Apr 05 19:22:10 2010] [notice] caught SIGTERM, shutting down
[Mon Apr 05 19:22:12 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Mon Apr 05 19:22:12 2010] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny8 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resu$
[Mon Apr 05 19:28:01 2010] [notice] Graceful restart requested, doing restart
[Mon Apr 05 19:28:06 2010] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny8 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resu$
[Mon Apr 05 19:28:06 2010] [warn] long lost child came home! (pid 22756)
[Mon Apr 05 19:29:02 2010] [notice] Graceful restart requested, doing restart
[Mon Apr 05 19:29:06 2010] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny8 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resu$
[Mon Apr 05 19:29:06 2010] [warn] long lost child came home! (pid 22873)
[Mon Apr 05 19:31:01 2010] [notice] caught SIGTERM, shutting down
[Mon Apr 05 19:31:02 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Mon Apr 05 19:31:02 2010] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny8 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resu$
[Mon Apr 05 19:32:01 2010] [notice] caught SIGTERM, shutting down
[Mon Apr 05 19:32:03 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Mon Apr 05 19:32:03 2010] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny8 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resu$
[Tue Apr 06 07:32:41 2010] [error] [client 192.168.1.27] File does not exist: /var/www/favicon.ico
[Tue Apr 06 07:32:44 2010] [error] [client 192.168.1.27] File does not exist: /var/www/favicon.ico
[Tue Apr 06 07:36:23 2010] [error] [client 192.168.1.27] client denied by server configuration: /var/www/sufuku.net
[Tue Apr 06 07:36:37 2010] [error] [client 192.168.1.27] client denied by server configuration: /var/www/sufuku.net/web/index.html
[Tue Apr 06 19:45:32 2010] [error] [client 192.168.1.27] File does not exist: /var/www/favicon.ico
[Tue Apr 06 19:45:35 2010] [error] [client 192.168.1.27] File does not exist: /var/www/favicon.ico


KZeeSoft 14th April 2010 20:22

any clue? Im trying to figure it out still - this is now week 2!

drieschel 14th April 2010 20:42

Hi KZeeSoft,

try to set the "AllowOverride" directive to "All" in the virtual host or remove the .htaccess file from the wordpress directory.

KZeeSoft 15th April 2010 06:37

Tried doing that fix in the vhost file for the site, removed .htaccess, still nothing. I replaced the .htaccess and still nothing.

I want to make it clear that I can't get the install.php file to work, that is where I get the 500 error. adding a .txt file to the directory worked fine, but the install.php file will not run.

drieschel 15th April 2010 10:24

Who is the owner from the wp dir? and which rights has it's content? ls -l /path/to/wordpress/

Edited.

till 15th April 2010 10:37

You looked into the wrong error log. Please look into the error log of the website ´which is in the log directory of the website and not the global error log. You will find the error message for your 500er error there.

Please do not do the chmod 777 as this might mess up your ispconfig setup.

KZeeSoft 15th April 2010 21:22

Here is the error.log I think you are looking for. These entries relate to the error, and seem to repeat. We are on the right track it seems.

Any suggestions?

Code:

[Mon Apr 05 16:30:06 2010] [error] [client 208.115.138.254] Premature end of script headers: install.php
[Mon Apr 05 16:30:07 2010] [error] [client 140.108.1.12] SoftException in Application.cpp:296: UID of script "/var/www/clients/client0/web1/web/forums/wp-adm
in/install.php" is smaller than min_uid
[Mon Apr 05 16:30:07 2010] [error] [client 140.108.1.12] Premature end of script headers: install.php
[Mon Apr 05 16:32:49 2010] [error] [client 140.108.1.12] SoftException in Application.cpp:296: UID of script "/var/www/clients/client0/web1/web/forums/wp-adm
in/install.php" is smaller than min_uid
[Mon Apr 05 16:32:49 2010] [error] [client 140.108.1.12] Premature end of script headers: install.php
[Mon Apr 05 16:33:04 2010] [error] [client 208.115.138.254] Directory index forbidden by Options directive: /var/www/clients/client0/web1/web/forums/
[Mon Apr 05 16:33:04 2010] [error] [client 140.108.1.12] Directory index forbidden by Options directive: /var/www/clients/client0/web1/web/forums/
[Mon Apr 05 16:36:29 2010] [error] [client 208.115.138.254] SoftException in Application.cpp:296: UID of script "/var/www/clients/client0/web1/web/forums/wp-
admin/install.php" is smaller than min_uid
[Mon Apr 05 16:36:29 2010] [error] [client 208.115.138.254] Premature end of script headers: install.php
[Mon Apr 05 16:36:29 2010] [error] [client 140.108.1.12] SoftException in Application.cpp:296: UID of script "/var/www/clients/client0/web1/web/forums/wp-adm
in/install.php" is smaller than min_uid
[Mon Apr 05 16:36:29 2010] [error] [client 140.108.1.12] Premature end of script headers: install.php


till 15th April 2010 21:25

You use a option in the .htaccess (Indexes) which is not allowd by the allowoverride setting of your system. So there are two options to solve this:

a) Remove the "Indexes" directive from the .htaccess file, as it is not nescessary on a ispconfig system.

or b) Set allow override to "All" on the options tab of the website settings in ispconfig.


All times are GMT +2. The time now is 00:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.