HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Offline Services (http://www.howtoforge.com/forums/showthread.php?t=44619)

grillonic 4th April 2010 19:50

Offline Services
 
I'm running ISPConfig3 in a VPS with CentOS 5.4
I've installed everything and it works fine, except for 3 servers, that are offline...

Under the Monitor section I get this...
http://grab.by/3wO7

Can anyone help me to fix it?? thanks!

I tried to start the dovecot daemon but this is the output...
Quote:

# /etc/init.d/dovecot start
Starting Dovecot Imap: Error: Error in configuration file /etc/dovecot.conf line 715: Unknown protocol name (section changed in /etc/dovecot.conf at line 709)
Fatal: Invalid configuration in /etc/dovecot.conf
[FAILED]
Also, when I run "yum update" I got this missing dependency:
Quote:

--> Finished Dependency Resolution
libpqxx-2.6.9-3.el5.rf.x86_64 from installed has depsolving problems
--> Missing Dependency: libpq.so.4()(64bit) is needed by package libpqxx-2.6.9-3.el5.rf.x86_64 (installed)
dovecot-1.0.7-7.el5.x86_64 from installed has depsolving problems
--> Missing Dependency: libpq.so.4()(64bit) is needed by package dovecot-1.0.7-7.el5.x86_64 (installed)
apr-util-1.2.7-7.el5_3.2.x86_64 from installed has depsolving problems
--> Missing Dependency: libpq.so.4()(64bit) is needed by package apr-util-1.2.7-7.el5_3.2.x86_64 (installed)
Error: Missing Dependency: libpq.so.4()(64bit) is needed by package libpqxx-2.6.9-3.el5.rf.x86_64 (installed)
Error: Missing Dependency: libpq.so.4()(64bit) is needed by package apr-util-1.2.7-7.el5_3.2.x86_64 (installed)
Error: Missing Dependency: libpq.so.4()(64bit) is needed by package dovecot-1.0.7-7.el5.x86_64 (installed)
I don't really know if the can cause the problem, but there it says "needed by package dovecot..." and that freaks me out ahahha

well PLEASE HELP thank you!

grillonic 5th April 2010 09:45

I managed to get myDNS
 
this is the current problem mates, I got two services down, says ISPConfig3 http://grab.by/3xvX

PLEASE HELP

falko 5th April 2010 19:41

What's in lines 709 and 715 of /etc/dovecot.conf?

grillonic 5th April 2010 20:03

Quote:

Originally Posted by falko (Post 224217)
What's in lines 709 and 715 of /etc/dovecot.conf?

Thank you so much for you reply mate, I did yum remove dovecot, then install it again and it worked :S

Never the less now SMTP-Server is Offline, and I don't know how to restart it :S http://grab.by/3xXT

falko 6th April 2010 16:09

Any errors in your mail log?
Please try
Code:

/etc/init.d/postfix restart

grillonic 6th April 2010 21:07

that kinda work...
 
Well I just reinstall the whole postfix package and it started working, but now I have this other issue (they just don't stop >.<!)...

I wrote to my VPS provider and they ran a test on my server, they told me this:
Quote:

As for ISPConfig, I see a lot of error in your Apache error_log:


BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 147.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 147.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 147.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 147.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 147.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 147.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 147.
And I guess that explains why my ISPConfig panel, all of a sudden and at random periods of time, just stop working, I mean, I just can't even see the welcome screen.

To "fix it" I just reload apache and I can enter again to the panel. On the other hand, if i'm on session and ISPConfig stops, the next warning appears in the browser http://grab.by/3zuz

Hope somebody can help.

falko 7th April 2010 17:16

Please install the Date::Format Perl module:

Code:

perl -MCPAN -e shell

install Date::Format

q


grillonic 15th April 2010 01:10

That help a bit
 
Quote:

Originally Posted by falko (Post 224409)
Please install the Date::Format Perl module:

Code:

perl -MCPAN -e shell

install Date::Format

q


Sry' bout' tha delay. Your advice worked... in some way, but I still got some httpd errors, and I'm very confused :confused:. At least my ISPConfig panel doesn't crash anymore, but... I just can't point my domains to my VPS :(, is there's any guide on, how to add DNS zones or stuff?

By the way check my error.log, you'll see what i'm talkin' about http://bit.ly/d9zZgd


All times are GMT +2. The time now is 15:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.