HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Kernel Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=6)
-   -   Can't See All Memory - CentOS 4.2 (http://www.howtoforge.com/forums/showthread.php?t=4452)

technick 22nd May 2006 15:26

Can't See All Memory - CentOS 4.2
 
I am in the process of setting up some servers, IBM X360 rack servers. They are decked out with 16 gigs of memory and quad xeon processors per system. CentOS is only seeing 8 gigs of the 16. I checked the BIOS, and the BIOS is reporting 16 gigs of ECC Registered memory correctly.

I did some research and saw IBM recommending I use the EL Hugemem kernel, so I went out and tried that. Still the same results. Here's the current kernel information.

Code:

[root@vs1 ~]# uname -a
Linux vs1.streamfire.net 2.6.9-34.ELhugemem #1 SMP Wed Mar 8 00:47:12 CST 2006 i686 i686 i386 GNU/Linux
[root@vs1 ~]# free
            total      used      free    shared    buffers    cached
Mem:      8032148    8012260      19888          0      9956    7730756
-/+ buffers/cache:    271548    7760600
Swap:    16386292          8  16386284
[root@vs1 ~]#

I was trying to advoid rebuilding the kernel, but I have a feeling I might have too.

Any advice / suggestions would be greatly appreciated.

Thanks in advance.

Nick

technick 22nd May 2006 19:39

Update...
 
I went ahead and compiled a new kernel based off of the current config with a few changes and still the same issue. I compiled 2.6.17 with the same results. I verified that largemem was available and it was set for 64 gigs of memory.

I need help guys......

I'll be patiently waiting...

falko 23rd May 2006 00:17

Have a look here: http://www.2cpu.com/forums/printthread.php?t=74951
http://lists.centos.org/pipermail/ce...il/063467.html

Maybe the problem is that you use the 32-bit CentOS version instead of the 64-bit one.


All times are GMT +2. The time now is 20:40.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.