HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   How To ISP install (Ubuntu 5.10 / Fedora 5) (http://www.howtoforge.com/forums/showthread.php?t=4439)

DVS 21st May 2006 11:37

How To ISP install (Ubuntu 5.10 / Fedora 5)
 
Hey there. :)

I'm a newB :cool:

I'm strugeling with something STUPID I know and the awnser is right infront of me but I'm blinded by my own noobness.

I'm trying to install the ISP server for Ubuntu OR Fedora (I tried both) and I get stuck at the same place -
after installation at the "trying to update and install the software packages".

I followed the tutorials (both) to the detail (and up to this point of the install that is not a lot!!!) but when I get to "apt-get update" in Ubuntu, it searches for the repo's (the ones I changed it to - us / de you name it, I've tried them) but gives errors (Can't connect etc etc.)

With Fedora same thing. When I get to the "yum install fetchmail wget bzip2 unzip zip nmap openssl lynx fileutils ncftp" it starts out trying to install but konks out for some unknown reason.

I have a static IP, netmask, gateway and 2 DNS IP's. With Ubuntu I have NO idea where to put the DNS's. But the problem persists with Fedora having a section just for DNS IP's in the GUI installation....weird thing is I don't even have to insert the DNS's, Fedora picks them up on it's own! Only thing I don't have is a domain name (that will come once my server runs).

Once installed I "ifconfig" and Bob is my uncle and I ping my router and it works. I ping the "to be server" and it gets picked up. I do a full install of Ubuntu using these IP settings and I update as happely as anything but as soon as I go "server" on any of the two distro's I get stuck at getting the packages.

What can it be that I am missing??? could I be so blind?

Any info will be appreciated thank you. :eek:

till 21st May 2006 14:02

Please check the nameservers in the file:

/etc/resolv.conf

DVS 21st May 2006 14:20

resolve.conf
 
Hey there, thanks for the reply...

Well, resolve.conf looks to be right - now I know where the DNS IP's go thnx :)

it looks like:

'
search co.za
nameserver "some.IP.here"
nameserver "another.IP.here"
'
'
'
'

These IP's are the correct ones...quadroopaly x 7 checked.

I'm currently trying the Fedora install so here's what it sais trying to do the "yum"...

--------
Loading "installonlyn" plugin
Setting up install process
Setting up reposiroties
updates [1/3]
---------
now it idle's a bit....
then this:

Cannot find the valid baseurl for repo: updates
Error: Cannot find a valid baseurl for repo: updates

then back to root prompt.

:confused:

till 21st May 2006 14:23

What result do you get when you ping google:

ping -c 3 www.google.com

DVS 21st May 2006 15:08

Getting off the hook
 
:rolleyes: :rolleyes: :rolleyes:

So when comes the first issue if "A Day in the life of the newB"??

At least this will entertain you if nothing else...
I've been working on this ALL day since 7 yesterday morning till 23:40
last night. 5 installations, two diffirent loser pc's later...I just checked my cabels
and realise (to a certain...I don't know what) that pc A is plugged into the router while pc B is not. PC B is the newly installed pc so no wonder I cant connect to the net. But this is where I will quit pondering...last night I pinged my router from pc B and picked it up........maybe I should write to the makers of "The Twilight ZoNe"?

Thank you for your concern and help though...

P.S. - now I know how to try and ping google aswell seeing that I tried that not knowing how to do it correctly...thnx :)


All times are GMT +2. The time now is 18:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.