HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Perfect setup x68_64[ispconfig 3] issue (http://www.howtoforge.com/forums/showthread.php?t=44188)

Fubar 18th March 2010 17:44

Perfect setup x68_64[ispconfig 3] issue
 
Hi,

I'm having issues on receiving emails on a fresh setup. I've run a Postfix/Dovcot setup for my personal email for years but my work recently had to leave a windows box up so I put my hand up and offered to setup a linux solution and get rid of windows. I'm a developer(php/.NET) here so this isn't 100% my fortay.

I ran through your great guide 2 or 3 times to iron out the bits I wasn't to sure on and I'm quite confident I set it up correctly bar one step at the start (I added http://dev.centos.org/centos/$releasever/testing/$basearch/ repo in order to update php to 5.2.10)

The issues that I'm gettinng I'm assuming are all related:
- UBE messages returned to a majority of emails trying to be sent to any of the 6 domains being hosted on the box
- the root (root@localhost) user on the box is getting a great deal of emails though I have not set this address anywhere (200 or so a day)
- Users are peridiodicly getting UBE messages related to sending email to themselves though they have never actually done this IE
(A message from <oliver.s@domain-web.co.uk>
to: oliver.s@domain-web.co.uk)

Other than this it seems ot be running perfecly.

I have never dealt with SPF records before so that could be an issue (I'm a MCSE and would like to think I understand DNS) but would love any help anyone can shed there.

I don't really know where to go next. I've played around with the settings in amavisd to PASS a lot of the email it would originally discarded or returned but to no avail. I've read up on SPF records and double /treble checked the mx records (plus tested with third party apps).
I can't see a pattern appearing with the emails that are not being recieved. I will send a email a few times from my own account and it will com up as BCE then send one an hour later after not changing anything and it will come through fine

I was converted from windows a long time ago and really don't want this to fail and give the M$ techies here a bad impression of it just becasue of a terrible experience with it now.

Thanks in advance, any responce will be a help (I feel like I have wasted my time for 2 days now)

I've not added any logs there but only as I'm not sure what you'll ask for.

till 18th March 2010 18:05

Quote:

- the root (root@localhost) user on the box is getting a great deal of emails though I have not set this address anywhere (200 or so a day)
Check /etc/aliases file, centos contains a lot of default aliases there. Remove all aliases that you dont need and run the newaliases command afterwards.

Fubar 19th March 2010 10:16

All of the emails in root are error emails not emails being sent in and arriving there though catch all or such.

They are all either UBE messages

or

This is the mail system at host domain-web.co.uk.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<root@localhost.co.uk>: mail for localhost.co.uk loops back to myself

falko 19th March 2010 16:33

Please add localhost.co.uk to the mydestination line in /etc/postfix/main.cf and restart Postfix.

Fubar 19th March 2010 17:04

Thanks, I've added that.
I'll see how it goes.

Fubar 22nd March 2010 11:16

THis doesn't appear to of helped change anything.
Come in Monday morning to a few disgruntled employees.

I have tried to bypass a lot of amavis checks in the conf file but is there any easy way to skip the check completely temperarily to find out if that is the problem at all?

till 22nd March 2010 11:21

If you want to disable amavis completely, commevt out the content_filter line in postfix main.cf and restart amavisd.

Fubar 22nd March 2010 12:00

Would amavis be the culprit service for blocking emails due to UBE?

falko 23rd March 2010 17:29

Can you post your main.cf? Do you use any blacklists in it?


All times are GMT +2. The time now is 12:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.