HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   MyDNS fails to start (http://www.howtoforge.com/forums/showthread.php?t=44106)

tristanlee85 15th March 2010 00:22

MyDNS fails to start
 
I've noticed in the ISPConfig 3 monitor it shows MyDNS as being off-line. Upon trying to start the service, I get this:
Code:

[root@server1 ~]# /etc/init.d/mydns restart
Stopping mydns:                                            [FAILED]
Starting mydns: mydns[2085]: Error connecting to MySQL server at localhost: Access denied for user 'username'@'localhost' (using password: YES) (errno=0)
                                                          [FAILED]

Here is my start-up config:
Code:

[root@server1 ~]# chkconfig --list | grep mydns
mydns                  0:off        1:off        2:on        3:on        4:off        5:on        6:off

I recall in the documentation to set this up that the password would be set during the ISPConfig installation. I ran update.php to re-configure everything, ensuring I didn't leave anything incorrect. Still, the service won't start.

Editing /etc/mydns.conf I see the values are default, so I change them:
Code:

##
##  /etc/mydns.conf
##  Fri Sep 21 21:44:51 2007
##  For more information, see mydns.conf(5).
##


                                # DATABASE INFORMATION

db-host = localhost            # SQL server hostname
db-user = root                  # SQL server username
db-password = XXXXX    # SQL server password
database = dbispconfig                  # MyDNS database name

Now it connects, however, that database doesn't seem to contain the correct tables needed for MyDNS.

Did I miss something?

tristanlee85 15th March 2010 06:35

From what I've read, ISPConfig 3 does not support BIND yet the interface mentiones BIND in the Server Configuration section along with
Quote:

Configuring Postfix
Configuring Jailkit
Configuring SASL
Configuring PAM
Configuring Dovecot
Configuring Spamassassin
Configuring Amavisd
Configuring Getmail
Configuring Pureftpd
Configuring BIND
Configuring Apache
Configuring vlogger
Configuring Apps vhost
Configuring Database
Configuring Firewall
when I install.

This is odd. I followed exactly the steps in the Perfect Server setup for Fedora 12.

till 15th March 2010 15:43

Looks as if you had bind and mydns package installed which confused the installer. Please remove bind with yum and run the ispconfig update again.

tristanlee85 15th March 2010 15:46

Thanks for the reply. I will give that a shot later.

ciscokid 15th March 2010 19:20

I had the same problem
 
Thanks tristanlee85 for starting the thread and till for your solution!

I had exactly the same issue with Centos 5.4 (32bit) install with ISPConfig 3 and had followed exactly the same setup as for the 64bit 5.4 and 32 bit 5.2.

I unistalled bind using yum and uninstalled ISPConfig and re-installed it rather than doing the update (which I'm sure would have worked anyway).

The problem I am still getting (and I'm sure this is only an CentOs issue) is a dovecot issue

Quote:

Stopping Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Stopping Dovecot Imap: [FAILED]
Error: Error in configuration file /etc/dovecot.conf line 715: Unknown protocol name (section changed in /etc/dovecot.conf at line 709)
Fatal: Invalid configuration in /etc/dovecot.conf
Starting Dovecot Imap: [FAILED]
Stopping httpd: [ OK ]
[Mon Mar 15 16:52:32 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
Starting httpd: [ OK ]
Stopping pure-ftpd: [ OK ]
Starting pure-ftpd: [ OK ]
Installation completed.
[root@mcisp01 install]#
I dont mean to hijack your thread tristanlee85

Cheers

ciscokid 15th March 2010 19:23

Looking at the dovecot.conf file, this is waht I see

Quote:

706 # missing. This option simply sends it if it's missing.
707 # The list is space-separated.
708 #pop3_client_workarounds =
709 }
710
711 ##
712 ## ManageSieve specific settings
713 ##
714
715 protocol managesieve {
716 # Login executable location.
717 #login_executable = /usr/libexec/dovecot/managesieve-login

tristanlee85 15th March 2010 19:24

Hey no problem. I also made a thread about the Dovecot issue. What I did was uninstalled bind and dovecot :

Code:

yum remove bind dovecot
And then ran:

Code:

php -q update.php
And it configured for Courier and MyDNS, and I not longer got the dovecot errors like you and I previously got.

I don't know if the tutorial installs bind and dovecot, or if it was a default package installed. I think it might be worth making a note in the tutorial (if it isn't already there; I didn't see one) to uninstall bind and dovecot for a ISPConfig 3 server since it doesn't seem to support those services.

till 15th March 2010 20:11

Ispconfig supports bind and dovecot starting from 3.0.2, but as you initially installed your systems with 3.0.1.6, you use courier and mydns instaed (which gives you basically the same functionality then bind and dovecot) and in this case, dovecot and bind should not be installed. The perfect setup tutorial does not mention it yet as it has not been updated for ispconfig 3.0.2 yet.

tristanlee85 15th March 2010 20:13

Ahh. I did find it odd that in previous posts I saw where bind wasn't supported, yet in the interface there was a section specifically labeled for bind. Either way, I got it working with MyDNS and Courier so I think I am happy. Thanks for the help!

till 15th March 2010 20:16

Just as reference for readers of this post: the latest install instructions for Centos 5.4 and Fedora 12 with Bind and Dovecot are available as txt files in the docs folder of the ispconfig 3.0.2 tar.gz file.


All times are GMT +2. The time now is 12:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.