HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Apache - mod_fcgid issue (http://www.howtoforge.com/forums/showthread.php?t=44062)

robertlouwen 12th March 2010 18:00

Apache - mod_fcgid issue
 
1 Attachment(s)
Hello all,

On my newly installed server I have created two sites with php-fast/cgi
When I restart apache i get these errors:
Socketpath cannot occur within < Virtualhost > section
MaxProcessCount cannot occur within < Virtualhost > section

Apache failed to start !

Now back in ISPConfig I change the sites to php-Suphp and restart Apache and everything is fine.

I attached the "naughty" ../sites-enabled/something.org.vhost

PS I followed this tutorial "Perfect server Fedora 12 with ISPConfig 3.0.2" with a i686 box.
I build it with copy and paste

till 12th March 2010 18:04

May you please remove this large dotted line from your addy, it breaks the layout. Thanks.

robertlouwen 12th March 2010 18:11

offcourse !

till 12th March 2010 18:22

If the mod_fcgi settings do not work on your system, its most likely to an incompatibility in mod_fcgid versions as they work e.g. on Debian. I will have to take a look why Fedora 12 does not support this. You can remove the lines in the file /usr/local/ispconfig/server/conf/vhost.conf.master

robertlouwen 12th March 2010 18:31

Again good evening Till,

I understand how much work it is to make all these tutorials and I can imagine that you don't have the time to test every possible server config.
That's why I posted this issue, not to nag you, I can live with php-Suphp, but to "help" you make a perfect server.

rudisoft 19th March 2010 08:20

Confirmation
 
Hello everyone,

Just wanted to confirm that i have the exact same problem.

I am using Fedora 12 x86_64 and apache won't start unless those 2 lines are disabled.
Other than that mod_fcgid seems to work ok (managed to get phpinfo).

Thanx!

robertlouwen 2nd April 2010 00:28

Update
 
Problem seems to be solved with ISPConfig v3.0.2.1 !

bajodel 2nd April 2010 02:41

..but the large dotted line from your addy ..still there :)


All times are GMT +2. The time now is 05:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.