HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Perfect Server - Ubuntu 8.04 LTS) postfix/smtp 25 connection refused (http://www.howtoforge.com/forums/showthread.php?t=44034)

wanderer 11th March 2010 19:27

Perfect Server - Ubuntu 8.04 LTS) postfix/smtp 25 connection refused
 
The Perfect Server - Ubuntu Hardy Heron (Ubuntu 8.04 LTS Server) - Page 5

telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 server.example.com ESMTP Postfix (Ubuntu)
ehlo localhost
250-server.example.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN


nmap localhost

Starting Nmap 4.53 ( http://insecure.org ) at 2010-03-11 19:26 EET
Interesting ports on localhost.localdomain (127.0.0.1):
Not shown: 1706 closed ports
PORT STATE SERVICE
21/tcp open ftp
22/tcp open ssh
25/tcp open smtp
53/tcp open domain
80/tcp open http
443/tcp open https
953/tcp open rndc
3306/tcp open mysql

Nmap done: 1 IP address (1 host up) scanned in 0.306 seconds


Mar 11 18:59:39 server postfix/smtp[4722]: A6BEB10059: to=<user@server.example.com>, relay=none, delay=0.41, delays=0.13/0.07/0.21/0, dsn=4.4.1, status=deferred (connect to server.example.com[ip]:25: Connection refused)

I replace the real name of server with server.example.com.

topdog 12th March 2010 11:42

Your nmap and telnet are to the localhost, something is blocking you from connecting to the servers actual ip address check your firewalls and also check to see that the server is listening to port 25 on that address

wanderer 15th March 2010 15:59

Ok i understand but i try to send mail local from one user to other. And here a results from outside of LAN.
Starting Nmap 5.21 ( http://nmap.org ) at 2010-03-15 15:37 E. Europe Standard Time

Nmap scan report for server.example.com (xx.xx.xx.xx)

Host is up (0.095s latency).
Not shown: 87 filtered ports

PORT STATE SERVICE

21/tcp open ftp
22/tcp open ssh
25/tcp open smtp
53/tcp open domain
80/tcp open http
81/tcp closed hosts2-ns
110/tcp closed pop3
143/tcp closed imap
443/tcp open https
993/tcp closed imaps
995/tcp closed pop3s
3306/tcp open mysql
8081/tcp open blackice-icecap



Nmap done: 1 IP address (1 host up) scanned in 20.69 seconds

Back with an add, I uninstalled all the packages on the mail HOWTO except Postfix and from console I was able to send mail between users.


All times are GMT +2. The time now is 14:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.