HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   I installed Nagios and lost ISPconfig (http://www.howtoforge.com/forums/showthread.php?t=44015)

fooboo 11th March 2010 13:09

I installed Nagios and lost ISPconfig
 
I had a working install of ISPConfig with several virtual hosts for subdomains.
I installed Nagios which adds itself as http://<domain>/nagios
Nagios works fine on that domain and directory but now nothing else does.
I can't connect to ISPConfig and none of my websites will serve, for all of them and ISPConfig I get the message "Forbidden You don't have permission to access / on this server."

To install nagios I had to add a user and a group for nagios and add the apache user to that group. Nagios sorted out the creation of the link to <domain>/nagios

From what I can tell either Nagios has either caused my system to use a different set of config files from the ones ISPconfig uses to serve my sites or something about the user permissions has stopped my sites being publicly available but I don't know enough to check out either theory.

The virtual hosts are still referred to in httpd.conf, the vhost files are still there in /sites-enabled so maybe it is a permissions thing.

Does anyone know how I could check this out or what permissions I need to set to get ISPconfig working again?

fooboo 11th March 2010 15:24

My apologies, n00b mistake. My first search didn't come up with the results I needed but after further searching I found this problem had already been answered elsewhere in this thread.

Installing Nagios somehow knocks the user "ispconfig" out of the apache group so simply adding it back "/usr/sbin/usermod -a -G ispconfig apache" sorted out the problem.


All times are GMT +2. The time now is 05:21.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.