HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Postfix & Dovecot Only (Arch Linux) (http://www.howtoforge.com/forums/showthread.php?t=43762)

carlosinfl 2nd March 2010 02:43

Postfix & Dovecot Only (Arch Linux)
 
I was looking at the following guide which shows me how to configure Arch Linux with Postfix, Spamassassin, Dovecot, Procmail, & Postgrey.

Link

My question is I was trying to filter out what exactly would I need to get this working with simply using Postfix / Postgrey / Dovecot only. Basically get rid of Spamassassin & Procmail from the mix.

I have posted below what I assume I would only need in my main.cf file:

Code:

# Paths
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
mail_owner = postfix
# Domain settings
myhostname = mail.mydomain.tld
myorigin = $mydomain
mydomain = mydomain.tld
mydestination = $myhostname, localhost.$mydomain, localhost
# Timeout settings and other limits
delay_warning_time = 4h
unknown_local_recipient_reject_code = 450
minimal_backoff_time = 300s
maximal_backoff_time = 1200s
maximal_queue_lifetime = 1d
bounce_queue_lifetime = 1d
smtp_helo_timeout = 60s
smtpd_soft_error_limit = 3
smtpd_hard_error_limit = 12
# SMTP settings
smtpd_tls_cert_file=/etc/ssl/certs/mail.crt
smtpd_tls_key_file=/etc/ssl/private/mail.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:/var/lib/postfix/smtpd_scache
smtp_tls_session_cache_database = btree:/var/lib/postfix/smtp_scache
smtpd_tls_loglevel = 1
smtpd_sasl_auth_enable = yes
#smtp_sasl_auth_enable = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,
                              permit_mynetworks,
                              reject_unauth_destination,
                              check_policy_service inet:127.0.0.1:10030
smtpd_sender_restrictions = permit_sasl_authenticated, permit_mynetworks
smtpd_sasl_security_options = noanonymous
# SASL
smtpd_sasl_type = dovecot
smtpd_sasl_path = /var/run/dovecot/auth-client
# Network settings
inet_interfaces = all
inet_protocols = ipv4
mynetworks = 127.0.0.0/8
relayhost =
# Email and mailbox settings
alias_maps = hash:/etc/postfix/aliases
alias_database = $alias_maps
home_mailbox = mail/
mailbox_size_limit = 0
# Misc
smtpd_banner = $myhostname ESMTP
biff = no
append_dot_mydomain = no
debug_peer_level = 2
sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/man
sample_directory = /etc/postfix/sample
readme_directory = no
recipient_delimiter = +

I removed:

Code:

virtual_alias_domains = example.com
virtual_alias_maps = hash:/etc/postfix/virtual
mailbox_command = /usr/bin/procmail

I didn't install 'procmail' & 'spamassassin' either via Pacman.

I didn't make any changes to /etc/postfix/master.cf file since the changes appeared to only be for 'spamassassin' and nothing else.

Do you guys see any issues with my main.cf above in having mail work with out SA & Procmail? I really don't see the reasoning for 'virtual_alias_maps' & 'mailbox_command'.
Thanks for any input and or suggestions.

-Carlos


All times are GMT +2. The time now is 20:11.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.