HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Spam Assassin problem during sa-update (http://www.howtoforge.com/forums/showthread.php?t=43660)

Been Told 24th February 2010 20:15

Spam Assassin problem during sa-update
 
My Spam Assassin was throwing false errors because of the date bug described here:
http://www.faqforge.com/linux/how-to...ast_20xx-rule/

So I ran "/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update" as described in the tutorial. But that gave me this output:
Quote:

Can't locate LWP/UserAgent.pm in @INC (@INC contains: /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.10.0 /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update line 79.
BEGIN failed--compilation aborted at /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update line 79.
Any ideas anyone? The server is running on Debian Lenny, ISPConfig 2.

Also, sometimes when I write to someone and they reply to me, there's a "-->" just before my e-mail. This also happens when I send e-mail to myself. So it must be something on my server.

falko 25th February 2010 17:07

Can you try this?
Code:

aptitude install liblwpx-paranoidagent-perl

Been Told 25th February 2010 18:02

Looks like that did it! :) I ran the sa-update line again and now it finished without errors. Danke Falko :)

Mikymike 9th June 2010 15:25

I've done a brand new install of ISPConfig 2.2.36 after following completly the perfect setup for my debian 5 lenny distro and had the same problem.

Code:

aptitude install liblwpx-paranoidagent-perl
or
Code:

apt-get install liblwpx-paranoidagent-perl
Should be missing or in the installation script or in the perfect setup

Then I've done:
Code:

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
After doing those commands my spamassassin is filtering now correctly.

Thank you for everything and for your very good work on ISPConfig

Michael


All times are GMT +2. The time now is 22:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.