HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   RoundCube Sends but will not receive. (http://www.howtoforge.com/forums/showthread.php?t=43541)

happz 18th February 2010 19:11

RoundCube Sends but will not receive.
 
ISPConfig2 on CENTOS 5.4! All went well. Site emails work fine and no signs of any issues anywhere but if I try to email an ISP users i.e. admin@web1_site it bounces. If I login to RoundCube: web1_someID and send to my personal gmail or hotmail or whatever..it goes fine. Hit reply from those accounts and it bounces.

Help anyone?

hAppZ

till 19th February 2010 10:25

Please post the exact error message lines from the maillog.

happz 20th February 2010 00:05

Here are two messages. Thanks Till
 
Quote:

Originally Posted by till (Post 219739)
Please post the exact error message lines from the maillog.

Here is an example of two messages but it's hard to get an error message when everything works on the server end..it's just that when people email my admin web1 email account, they tell me days later that it bounced. Here are a couple of messages but there are more.

Code:

Feb 17 04:02:14 srv1 postfix/smtpd[6105]: 90AE630726: client=localhost.localdomain[127.0.0.1], sasl_sender=root@srv1.example.com
Feb 17 04:02:14 srv1 postfix/cleanup[6109]: 90AE630726: message-id=<201002170902.o1H929Fr005872@srv1.example.com>
Feb 17 04:02:14 srv1 postfix/qmgr[1606]: 90AE630726: from=<root@srv1.example.com>, size=28676, nrcpt=1 (queue active)
Feb 17 04:02:14 srv1 sendmail[5872]: o1H929Fr005872: to=root, ctladdr=root (0/0), delay=00:00:05, xdelay=00:00:00, mailer=relay, pri=57746, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 90AE630726)
Feb 17 04:02:14 srv1 postfix/smtpd[6105]: disconnect from localhost.localdomain[127.0.0.1]
Feb 17 04:02:14 srv1 postfix/local[6110]: 90AE630726: to=<root@srv1.example.com>, relay=local, delay=0.21, delays=0.13/0.01/0/0.06, dsn=2.0.0, status=sent (delivered to maildir)
Feb 17 04:02:14 srv1 postfix/qmgr[1606]: 90AE630726: removed



Feb 10 23:36:38 srv1 procmail[10628]: Couldn't rename bogus "/var/mail/admispconfig" into "/var/mail/BOGUS.admispconfig.8Qg"
Feb 10 23:36:38 srv2 postfix/local[10627]: 17D39306E3: to=<admispconfig@srv1.example.com>, relay=local, delay=16, delays=0.01/0.03/0/16, dsn=5.2.0, status=bounced (can't create user output file. Command output: procmail: Renaming bogus mailbox "/var/mail/admispconfig" info "/var/mail/BOGUS.admispconfig.8Qg" procmail: Couldn't create "/var/mail/admispconfig" )
Feb 10 23:36:38 srv2 postfix/qmgr[3191]: 17D39306E3: removed


falko 20th February 2010 13:42

What's the output of
Code:

ls -la /var/mail/
?

happz 21st February 2010 01:32

Here it is.
 
Quote:

Originally Posted by falko (Post 219820)
What's the output of
Code:

ls -la /var/mail/
?

Code:

total 20
drwxrwxr-x  2 root        mail 4096 Feb 10 19:27 .
drwxr-xr-x 17 root        root 4096 Feb  6 21:40 ..
-rw-rw----  1          500 mail    0 Feb 10 19:25 admispconfig
-rw-rw----  1 ispconfigend mail    0 Feb 10 19:27 ispconfigend
-rw-rw----  1 rpc          mail    0 Feb  6 21:03 rpc


thanks,
happz

falko 21st February 2010 15:23

Please run
Code:

chown admispconfig /var/mail/admispconfig

happz 21st February 2010 22:36

Okay, I ran this code and results are:
 
after running the code, i send to email address created in ispconfig for this website. The results are that I never receieved the email. So I decided to send out an email....I will say that i was able to send emails out but I did now test this before running that line of code but now, i cannot send out emails but the message is very interesting.

Here's the return message:
Code:

This is the mail system at host srv1.example.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                  The mail system

<DEFANGED_oneofmyemails@live.com>: host mail.bellsouth.net[204.127.217.17] said: 551 not our
    customer (in reply to RCPT TO command)
Reporting-MTA: dns; srv1.example.com
X-Postfix-Queue-ID: 19AE83071C
X-Postfix-Sender: rfc822; admin@mysiteinquestion.com
Arrival-Date: Sun, 21 Feb 2010 16:12:15 -0500 (EST)

Final-Recipient: rfc822; oneofmyemails@live.com
Original-Recipient: rfc822;oneofmyemails@live.com
Action: failed
Status: 5.0.0
Remote-MTA: dns; mail.bellsouth.net
Diagnostic-Code: smtp; 551 not our customer

I actually get two return error message per each email I try to send out but I only copied the one..if you want to see both let me know but this one looks strange to me. Not sure if this is related to any recent change. I am using email relay from bellsouth. I also changed the names of the servers.
Thanks,
happz

happz 22nd February 2010 00:38

Okay..update
 
weird thing but in my sasl_password reentered the relay email setting and rebooted and now i can send emails from roundcube but still cannot receive.

What can i do next guys..and thanks for your quick response and help so far!!

happz

falko 22nd February 2010 14:30

What's in your mail log when you send an email to your server?
Do the MX records of your domains point to your server? You can check that by running
Code:

dig mx yourdomain.com

happz 22nd February 2010 20:27

dig mx examplesite.com results
 
Quote:

Originally Posted by falko (Post 219998)
What's in your mail log when you send an email to your server?
Do the MX records of your domains point to your server? You can check that by running
Code:

dig mx yourdomain.com

Here's the results of dig mx exampletsite.com (changed names of site/server)
Code:

[root@srv1 ~]# dig mx examplesite.com

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> mx examplesite.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26658
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;examplesite.com.                  IN      MX

;; ANSWER SECTION:
example.com.          86400  IN      MX      10 srv1.example.com.

;; Query time: 72 msec
;; SERVER: 205.120.130.20#53(205.120.130.20)
;; WHEN: Mon Feb 22 14:20:43 2010
;; MSG SIZE  rcvd: 57

[root@srv1 ~]#


Mail LOG (there are many logs here so this is an example of some from the timeframe:

Code:

eb 22 15:03:29 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:03:29 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:03:29 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:03:29 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:03:31 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:03:31 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:03:32 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:03:32 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:03:47 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:03:47 srv1 sendmail[11115]: o1MK3l12011115: Authentication-Warning: srv1.example.com: admispconfig set sender to admin@lexamplesite.com using -f
Feb 22 15:03:47 srv1 sendmail[11115]: o1MK3l12011115: from=admin@lexamplesite.com, size=377, class=0, nrcpts=1, msgid=<d6be439fc43e1eb019b35b6cd5c5873b@localhost>, relay=admispconfig@localhost
Feb 22 15:03:47 srv1 postfix/smtpd[11116]: connect from localhost.localdomain[127.0.0.1]
Feb 22 15:03:47 srv1 postfix/smtpd[11116]: setting up TLS connection from localhost.localdomain[127.0.0.1]
Feb 22 15:03:47 srv1 postfix/smtpd[11116]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Feb 22 15:03:47 srv1 sendmail[11115]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Feb 22 15:03:47 srv1 postfix/smtpd[11116]: 7F9403072A: client=localhost.localdomain[127.0.0.1]
Feb 22 15:03:47 srv1 postfix/cleanup[11119]: 7F9403072A: message-id=<d6be439fc43e1eb019b35b6cd5c5873b@localhost>
Feb 22 15:03:47 srv1 postfix/qmgr[5560]: 7F9403072A: from=<admin@lexamplesite.com>, size=902, nrcpt=1 (queue active)
Feb 22 15:03:47 srv1 sendmail[11115]: o1MK3l12011115: to=<testusers@yahoo.com>, ctladdr=admin@lexamplesite.com (105/105), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30377, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 7F9403072A)
Feb 22 15:03:47 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:03:47 srv1 postfix/smtpd[11116]: disconnect from localhost.localdomain[127.0.0.1]
Feb 22 15:03:47 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:03:47 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:03:48 srv1 postfix/smtp[11120]: certificate verification failed for smtp.live.com: num=20:unable to get local issuer certificate
Feb 22 15:03:48 srv1 postfix/smtp[11120]: certificate verification failed for smtp.live.com: num=27:certificate not trusted
Feb 22 15:03:48 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:03:48 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:03:49 srv1 postfix/smtp[11120]: 7F9403072A: to=<testusers@yahoo.com>, relay=smtp.myrelayer.com[xxx.xxx.xxx.xxx]:587, delay=2.4, delays=0.07/0.05/1.5/0.7, dsn=2.6.0, status=sent (250 2.6.0  <d6be439fc43e1eb019b35b6cd5c5873b@localhost> Queued mail for delivery)
Feb 22 15:03:49 srv1 postfix/qmgr[5560]: 7F9403072A: removed
Feb 22 15:03:49 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:03:49 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:03:50 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:03:50 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:03:54 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:03:54 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:04:13 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:04:13 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:04:14 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:04:14 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:04:15 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:04:15 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:04:17 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:04:17 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out
Feb 22 15:04:17 srv1 dovecot: imap-login: Login: user=<web1_exampleadmin>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Feb 22 15:04:17 srv1 dovecot: IMAP(web1_exampleadmin): Disconnected: Logged out

I did change who i am relaying my emails through and all emails from my web1 site will work fine. I can even email from roundcube...just when i email admin@examplesite.com it will deliver.

thanks,
happz


All times are GMT +2. The time now is 10:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.