HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Can't send email to squirrelmail (http://www.howtoforge.com/forums/showthread.php?t=43437)

learning-linux 12th February 2010 15:42

Postfix receive mail problem
 
Hi all,


I installed "the perfect server debian i386 lenny ISPConfig" version. Everything is working just fine.

I thought! Yesterday i was testing squirrelmail and i could send an email from the server to my my emailaccount at home...GREAT ! The test was to reply that mail that mail to see if i could receive an email in my squirrelmail account ... and that didn't happend.

So i can send mail from any account made in ISPConfig, but i can't send it back from my computer to the server, so it would arrive in the webmail box

This is the code from the mail ..

Code:

info@huismedia.nl
    SMTP error from remote mail server after RCPT TO:<info@huismedia.nl>:
    host fallback.mail.widexs.nl [212.127.254.8]:
    550 all relevant MX records point to non-existent hosts





What is wrong?

learning-linux 12th February 2010 21:10

Õ have to say that the server is installed behind a router. But the static IP assigned to it, is in DMZ. Ports needed are opend in the router.

The problem is that i don't receive any email at the server. I can email from different clients to another at the same server... but when i send an email from a client from the server to a client thats not on the server it gets deliverd.

But when i want to reply ... every time i get it back..in my outlook mailbox... i never get's in the clients squirrelmail webmail box?


output of : postconf -n

Code:


floor:~# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
body_checks = regexp:/etc/postfix/body_checks
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
header_checks = regexp:/etc/postfix/header_checks
html_directory = /usr/share/doc/postfix/html
inet_interfaces = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
message_size_limit = 0
mime_header_checks = regexp:/etc/postfix/mime_header_checks
mydestination = floor.arosa.nl, localhost, localhost.localdomain
myhostname = floor.arosa.nl
mynetworks = 127.0.0.0/8 [::1]/128
myorigin = /etc/mailname
nested_header_checks = regexp:/etc/postfix/nested_header_checks
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virt                                                                                        ual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipien                                                                                        t_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonica                                                                                        l_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual                                                                                        _client.cf
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, che                                                                                        ck_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth                                                                                        _destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual                                                                                        _sender.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysq                                                                                        l:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_transport = maildrop
virtual_uid_maps = static:5000
floor:~# reset
floor:~# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
body_checks = regexp:/etc/postfix/body_checks
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
header_checks = regexp:/etc/postfix/header_checks
html_directory = /usr/share/doc/postfix/html
inet_interfaces = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
message_size_limit = 0
mime_header_checks = regexp:/etc/postfix/mime_header_checks
mydestination = floor.arosa.nl, localhost, localhost.localdomain
myhostname = floor.arosa.nl
mynetworks = 127.0.0.0/8 [::1]/128
myorigin = /etc/mailname
nested_header_checks = regexp:/etc/postfix/nested_header_checks
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_transport = maildrop
virtual_uid_maps = static:5000
floor:~#

Please help !

falko 13th February 2010 16:21

Please check if your MX records point to the correct server:
Code:

dig mx yourdomain.com

learning-linux 13th February 2010 17:57

Hi Falko,

Thanx for responding ... like my nickname say's .....learning linux.

Code:


; <<>> DiG 9.5.1-P3 <<>> mx floor.arosa.nl
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64752
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;floor.arosa.nl.                        IN      MX

;; AUTHORITY SECTION:
arosa.nl.              10800  IN      SOA    ns1.widexs.nl. hostmaster.widexs.nl. 2010021201 14400 3600 604800 86400

;; Query time: 33 msec
;; SERVER: 212.54.40.25#53(212.54.40.25)
;; WHEN: Sat Feb 13 18:00:35 2010
;; MSG SIZE  rcvd: 90

my host is widexs so it should be right ...i think?

falko 14th February 2010 14:17

There's no MX record, so you should create one.

learning-linux 14th February 2010 16:05

sorry my mistake ... you asked for dig MX example.com .... i did
dig MX server.examample.com

the output for dig MX arosa.nl (Floor is the server name in the example above)

Code:



floor:~# dig MX arosa.nl

; <<>> DiG 9.5.1-P3 <<>> MX arosa.nl
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36003
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 1

;; QUESTION SECTION:
;arosa.nl.                      IN      MX

;; ANSWER SECTION:
arosa.nl.              86347  IN      MX      10 mail.arosa.nl.

;; AUTHORITY SECTION:
arosa.nl.              7147    IN      NS      ns1.widexs.nl.
arosa.nl.              7147    IN      NS      ns3.widexs.nl.
arosa.nl.              7147    IN      NS      ns2.widexs.net.

;; ADDITIONAL SECTION:
mail.arosa.nl.          86347  IN      A      82.94.241.21

;; Query time: 108 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Sun Feb 14 15:44:39 2010
;; MSG SIZE  rcvd: 134

When i check QUESTION . ANSWER, AUTHORITY and ADDITIONAL section in the above output... that is correct.

My ISP IP adres is 84.105.43.140...

At the ISP host this are the settings

server floor.arosa.nl is assigned to A 84.105.43.140
webmail2 to CNAME 84.105.43.140
mail2 to A 84.105.43.140
pop2 to CNAME floor.arosa.nl
MX2 to A 84.105.43.140

the server is behind a router and has IP 192.168.1.13

ports opened on firewall , 80,110, 22, 53, 3306 , 110, 25 , 443 (both) udp en tcp

learning-linux 15th February 2010 01:20

Oke , news, according to mxtoolbox.com the server is blacklisted.

I have had contact so no have to wait,
bit after a upgrade is have the following errors in my

Mailqueue:
Code:

2A5C08DE362 3005 Mon Feb 15 00:25:23 MAILER-DAEMON
(temporary failure. Command output: pipe: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory)
info@huismedia.nl

B48C58DE387 2996 Sun Feb 14 16:51:04 MAILER-DAEMON
(temporary failure. Command output: pipe: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory)
alex@arosa.nl

DC2DB8DE38C 2990 Sun Feb 14 17:24:17 MAILER-DAEMON
(temporary failure. Command output: pipe: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory)
info@huismedia.nl

In the "show mail log"
Code:


Feb 15 00:56:12 floor pop3d: LOGIN, user=info@huismedia.nl, ip=[::ffff:84.105.43.140], port=[59003]
Feb 15 00:56:12 floor pop3d: LOGOUT, user=info@huismedia.nl, ip=[::ffff:84.105.43.140], port=[59003], top=0, retr=0, rcvd=12, sent=39, time=0
Feb 15 01:00:01 floor pop3d: Connection, ip=[::ffff:127.0.0.1]
Feb 15 01:00:01 floor pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Feb 15 01:00:01 floor imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 15 01:00:01 floor imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
Feb 15 01:00:01 floor postfix/smtpd[3034]: connect from localhost[127.0.0.1]
Feb 15 01:00:01 floor postfix/smtpd[3034]: lost connection after CONNECT from localhost[127.0.0.1]
Feb 15 01:00:01 floor postfix/smtpd[3034]: disconnect from localhost[127.0.0.1]
Feb 15 01:00:56 floor postfix/qmgr[2551]: 907A48DE334: from=, size=1174, nrcpt=1 (queue active)
Feb 15 01:00:56 floor postfix/qmgr[2551]: 2A5C08DE362: from=<>, size=3005, nrcpt=1 (queue active)
Feb 15 01:00:56 floor pipe[3067]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory
Feb 15 01:00:56 floor pipe[3068]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory
Feb 15 01:00:56 floor postfix/pipe[3065]: 907A48DE334: to=, relay=maildrop, delay=2154, delays=2153/0.07/0/0.02, dsn=4.3.0, status=deferred (temporary failure. Command output: pipe: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory )
Feb 15 01:00:56 floor postfix/pipe[3066]: 2A5C08DE362: to=, relay=maildrop, delay=2133, delays=2133/0.03/0/0.02, dsn=4.3.0, status=deferred (temporary failure. Command output: pipe: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory )

Mail warning log :

Code:


Feb 15 00:25:23 floor postfix/smtp[25228]: warning: host mail2.arosa.nl[84.105.43.140]:25 replied to HELO/EHLO with my own hostname floor.arosa.nl
Feb 15 00:25:23 floor pipe[25231]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory
Feb 15 00:31:23 floor pipe[25358]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory
Feb 15 00:31:23 floor pipe[25362]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory
Feb 15 00:31:23 floor pipe[25363]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory
Feb 15 00:31:23 floor pipe[25364]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory
Feb 15 00:40:56 floor pipe[2801]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory
Feb 15 00:40:56 floor pipe[2803]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory
Feb 15 01:00:56 floor pipe[3067]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory
Feb 15 01:00:56 floor pipe[3068]: fatal: pipe_command: execvp /usr/bin/maildrop: No such file or directory

maybe ...some one now understand what's the matter?

Kind regards

falko 15th February 2010 13:13

Quote:

mail.arosa.nl. 86347 IN A 82.94.241.21
IS 82.94.241.21 your server's IP address?

Please make sure that maildrop is installed on the system.

learning-linux 15th February 2010 13:26

Quote:

Originally Posted by falko (Post 219408)
IS 82.94.241.21 your server's IP address?

Please make sure that maildrop is installed on the system.

I just installed maildrop .. so that's 1.

Our main server is 82.94.241.21 (hostname "adinda") and hosted bij WideXS the server is placed at XS4all so mail.arosa.nl is ipadres 82.94.241.21 (server name is adinda) domain ( arosa )

i'm setting up a server ( Floor) to learn linux. i'm behind a router.
My public IP is 84.105.43.140 and we named this server Floor. i use
mail2.arosa.nl at public adres 84.105.43.140

i installed maildrop.... and i can send mail from the server( Floor) to a cliŽnt, replying to that adres (that domain hosted on the server Floor) will not be received.

I also don;t no of i have to make a DNSZone in ISPConfig...

learning-linux 15th February 2010 14:01

I don't know but ...this says more then my rubbish

http://www.mxtoolbox.com/SuperTool.a...a84.105.43.140


All times are GMT +2. The time now is 04:28.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.