HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   amavis & clamav - strange behaviour?! misconfiguration ? (http://www.howtoforge.com/forums/showthread.php?t=42965)

prisfeo 25th January 2010 10:30

amavis & clamav - strange behaviour?! misconfiguration ?
 
hi i am newbie here :)
i have installed perfectly without any errors or warnings ISP 3.0.1.6 onto Centos 5.4 server; following the perfect related guide at your site! :)

i have tested sending a virus message(eicar test file attached) to a test user @ domain newly created inside ispconfig in order to check spam/virus detections;
well, seeing /var/log/maillog i can see virus is correctly detected and blocked
("Blocked INFECTED (Eicar-Test-Signature)")
but a line log before i see:

"amavis[31018]: (31018-03) (!!)WARN: all primary virus scanners failed, considering backups"

(i have removed my sensible server data name)

so i have goggled for a solution ad i saw it is related to privileges of user "clamav" in relation to amavis group..
so i checked, but user "clamav" is correctly already a member of "amavis" group;
so i checked the socket configuration:
in /etc/clamd.conf
-> LocalSocket /var/run/clamav/clamd.sock

and /etc/amavisd/amavisd.conf
->
# ### http://www.clamav.net/
['ClamAV-clamd',
\&ask_daemon, ["CONTSCAN {}\n", "/var/run/clamav/clamd.sock"],
qr/\bOK$/, qr/\bFOUND$/,
qr/^.*?: (?!Infected Archive)(.*) FOUND$/ ],


and you can see that they match.

..so where is the problem ?
..
another "wrong" thing is that in /var/log/maillog
i saw the system tries to send email from=<virusalert@example.com>
but i have configured in ispconfig mydomain that is not "example.com"
if i check /etc/amavisd/amavisd.conf
i can see:
$mydomain = 'websites.nameofmydomain.it'; # a convenient default for other settings

so it is correct!
but i have discovered another configuration file in /etc:
/etc/amavisd.conf
and inside it there is:
$mydomain = 'example.com'; # a convenient default for other settings

so it seems,
there are two amavis configuration files :confused: ..so my question is:
what configuration file is used from ispconfig and by the server ?

in addition, i saw that (obviously i think)
in "second" amavis config file: /etc/amavisd.conf
the "clamav" related configuration is all commented


thanks in advance..,
bye,
prisfeo.

p.s.: forgive my poor english, i am not english.

prisfeo 25th January 2010 16:27

i have succeeded in resolving the above problem..
simply i have copied the
/etc/amavisd/amavisd.conf
in /etc folder
so overwriting the actual /etc/amavisd.conf
(that seems not configured by ispconfig, but used !)
now the clamav problem is gone away..
:)

pls, tell me if i have made the right thing..
however i wonder where it is written in ispconfig configuration
which "amavisd.conf" file to use
cause i think it have to be somewhat corrected

bye,
prisfeo.

rutame 25th January 2010 17:19

I want desactive Clamav and Spam Out of memory
 
Hello,

Could I deactive Clamav and spam, because my server run out of memory all time with this daemons. The server has 640MB es a virtual server, but i have got another server based p3 - 512MB and goes very good.

Or if somebody has any idea for this problem, i will be very happy and gratefull.

Thanks a lot

till 25th January 2010 17:24

640 MB is not enough ram for a full ispconfig 3 server. You can deactivate clamav and spamassassin if you dont need the mail protection and spam filtering by commenting out the content_filter line in postfix main.cf and stopping these daemons.

rutame 25th January 2010 21:15

Thank you Till,

And for an Ispconfig 2 its enought memory?

till 26th January 2010 10:11

For ISPConfig 2 its fine, as long as you dont have to much emails and visitors on your websites.

prisfeo 26th January 2010 12:38

hi Till..

just to know:
i have installed ISPconfig3 onto a linux server(not virtual) with Centos 5.4 with web&email services active (clamav, amavis, spamassassin,etc)..i think it will host about 30 joomla 1.5 web sites and manage about 60 email accounts (splitted in 30 different domains).
(i do not think visitors will be so many towards the websites)

the HW of the server is:
dual core intel Xeon 3.00 Ghz
1 GB RAM

..do you think is it suitable for the above tasks ?

till 26th January 2010 12:44

I would add another GB ram to speed up the system as ram is really cheap. But it should also work with your curent configuration, its not a vsever and the kernel is able to use swap temporarily. More ram has the benefit that mysql is able to create the temporary tables in ram instead on the harddisk and this will speed up the joomla sites as joomla uses mysql a lot.

rutame 26th January 2010 17:38

Quote:

Originally Posted by till (Post 217501)
I would add another GB ram to speed up the system as ram is really cheap. But it should also work with your curent configuration, its not a vsever and the kernel is able to use swap temporarily. More ram has the benefit that mysql is able to create the temporary tables in ram instead on the harddisk and this will speed up the joomla sites as joomla uses mysql a lot.

And an another last question... what i should use? cgi, fastcgi, mod-php...

In performance and consumer terms

Thanks a lot Till

till 27th January 2010 12:50

That depends on the site that you host, the number of pageviews etc. By the way, this question has already been answered several times here in the forum.


All times are GMT +2. The time now is 05:50.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.