HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Cannot Receive external mail - Postfix, Courier, MySQL And SquirrelMail (Debian Lenny (http://www.howtoforge.com/forums/showthread.php?t=42766)

x-built-Stan 18th January 2010 08:34

Cannot Receive external mail - Postfix, Courier, MySQL And SquirrelMail (Debian Lenny
 
I followed the virtual domain setup on the forge @ http://www.howtoforge.com/virtual-us...l-debian-lenny

When I send email from the local server via mailx it works fine and get to the virual user. I can log into SquirrelMail and see the message. However, when I send mail from any outside server it gets kicked with a 550 and the following message:

Generating server: hqpexedg02.admin.cci.edu

johndoe@mydomain.com
p3pismtp01-015.prod.phx3.secureserver.net #550 #5.1.0 Address rejected johndoe@mydomain.com ##

I have gone back throught eh tutorial several times and each of the checks, everything looks good. Can anyone assist?

Mark_NL 18th January 2010 10:29

Code:

tail -f /var/log/mail.log
- send another mail ..
- paste the lines that are generated from that mail here.

x-built-Stan 18th January 2010 19:44

Sent another message. No output in maill.log, mail.err, or syslog.

Same 550 error on bounced email.

x-built-Stan 18th January 2010 20:08

Sent another email. No output in the mail.log, mail.err, or syslog

falko 19th January 2010 16:10

Please check if the MX record of your domain points to the correct server. You can check that with
Code:

dig mx yourdomain.com

x-built-Stan 19th January 2010 19:53

Man - you nailed it on the head.

My ever so helpful DNS provider routed my MX record to their mail server. Changed it mine and everything is great.

I should have seen it - Thanks again.

kulot 22nd August 2014 09:50

Cannot Receive external mail - Postfix, Courier, MySQL And SquirrelMail (Debian Lenny
 
Hello sir. I have also followed the tutorial word by word in creating virtual user in CentOS 6.5.

I cannot open my squirrelmail account because I do not have any email yet (as based on the suggestion that the email created should have an email sent so that the email address can be opened during first time).

I wanted to send an email from gmail but my email bounces back. I have tried the "dig" command and this is the output:

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.23.rc1.el6_5.1 <<>> mx ndtc.edu.ph
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53509
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ndtc.edu.ph. IN MX

;; ANSWER SECTION:
ndtc.edu.ph. 18994 IN MX 10 mail.ndtc.edu.ph.

;; Query time: 272 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Fri Aug 22 14:50:32 2014
;; MSG SIZE rcvd: 50

my website is ndtc.edu.ph

I am hoping for a response.

srijan 25th August 2014 08:57

Did you followed the tutorial word to word? Did you installed mails and send the the welcome mail to create the account for email address?

Which guide you are following?

kulot 26th August 2014 16:31

Yes sir.I have already send an email but i guess it bounces back. his thread sir:

http://www.howtoforge.com/virtual-us...tos-6.3-x86_64

I have also send an email from gmail to my account in my domain but according to the maillog, it bounces back to the sender.


All times are GMT +2. The time now is 06:09.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.