HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   pear and change_sqlpass plugin (http://www.howtoforge.com/forums/showthread.php?t=42693)

sruedat 14th January 2010 19:38

pear and change_sqlpass plugin
 
Hello, I have tried to install the squirrelmail plugin change_sqlpass, so my clients can change they own password... but when I active the plugin this happen:

http://img694.imageshack.us/img694/3...uirrelmail.jpg


What happen?

I'm on suse 11.1

pear -V said:
PEAR Version: 1.5.0
PHP Version: 5.2.11
Zend Engine Version: 2.2.0

and pear install DB said:
pear install DB
Channel pear.php.net does not support xml-rpc method package.getDownloadURL
Cannot initialize 'DB', invalid or missing package file
Package "DB" is not valid
install failed

thanks for your help.

sruedat 15th January 2010 11:29

it was my fault, i have a problem in the config.php file.... i'm forggot "<?php", i'm i idiot...sorry.

But now in the webmail adress only appears a blank page... I'm doing somethin wrong.

Thanks.

falko 15th January 2010 14:37

Please make sure you introduced no PHP syntax error when you modified the config.php file of the change_sqlpass plugin.

sruedat 16th January 2010 09:50

thanks
 
I had followed this tutorial...and I had used this code.

http://www.howtoforge.com/how-to-con...onfig-3-server

Now I have used the config.php.sample... and the problem is solved;

But I think that I have problems with pear because when I try to change the pass this happen: "Could not find Pear DB library".

If I do pear list I get this:
Installed packages, channel pear.php.net:
=========================================
Package Version State
Console_Getopt 1.2.3 stable
DB 1.7.13 stable
PEAR 1.9.0 stable
Structures_Graph 1.0.3 stable
XML_Parser 1.3.2 stable
XML_Util 1.2.1 stable



Thanks for your infinite patient.

falko 16th January 2010 16:16

Try this:
Code:

aptitude install php-pear

pear install DB


sruedat 16th January 2010 17:02

I had done it yet...
I have done it again, but I have the same problem...: "Could not find Pear DB library"

I works in opensuse 11.1_X64: "yast -i php-pear php-pear-db"
in fact if you see the pear list the DB package appears.
thanks.

falko 17th January 2010 15:48

I have no idea why this happens... :(

sruedat 21st January 2010 21:53

I think the error is...
 
What would be the log file?, this is the apache error_log:
[Thu Jan 21 21:03:51 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Thu Jan 21 21:03:51 2010] [notice] Apache/2.2.10 (Linux/SUSE) mod_ssl/2.2.10 OpenSSL/0.9.8h PHP/5.2.11 with Suhosin-Patch mod_mono/2.0 configured -- resuming normal operations

Thanks.

sruedat 22nd January 2010 12:38

I solved it
 
I SOLVED IT!!! :D:D:D

There was a problem with the pear config....
The pear config-show must be so:
Quote:

Auto-discover new Channels auto_discover <not set>
Default Channel default_channel pear.php.net
HTTP Proxy Server Address http_proxy <not set>
PEAR server [DEPRECATED] master_server pear.php.net
Default Channel Mirror preferred_mirror pear.php.net
Remote Configuration File remote_config <not set>
PEAR executables directory bin_dir /usr/bin
PEAR documentation directory doc_dir /usr/share/php5/PEAR/doc
PHP extension directory ext_dir /usr/lib64/php5/extensions
PEAR directory php_dir /usr/share/php5/PEAR
PEAR Installer cache directory cache_dir /home/user/pear/pear/cache
PEAR data directory data_dir /usr/share/php5/PEAR/data
PEAR Installer download download_dir /tmp/pear/download
directory
PHP CLI/CGI binary php_bin /usr/bin/php5
php.ini location php_ini /etc/php5/apache2
PEAR Installer temp directory temp_dir /tmp/pear/temp
PEAR test directory test_dir /home/user/pear/pear/tests
Cache TimeToLive cache_ttl 3600
Preferred Package State preferred_state stable
Unix file mask umask 22
Debug Log Level verbose 1
cfg_dir <not set>
php_prefix <not set>
php_suffix <not set>
www_dir <not set>
PEAR password (for password <not set>
maintainers)
Signature Handling Program sig_bin /usr/local/bin/gpg
Signature Key Directory sig_keydir /etc/php5/cli/pearkeys
Signature Key Id sig_keyid <not set>
Package Signature Type sig_type gpg
PEAR username (for username <not set>
maintainers)
User Configuration File Filename /root/.pearrc
System Configuration File Filename /etc/php5/cli/pear.conf
Then I reinstalled the DB package and... it works

The problems was a wrong configuration (you can change it with pear config_set <param1> <param2>)
Thanks.

mutua 2nd April 2012 16:14

Am experiencieng same problem! which conf pricesly were incorrect.


All times are GMT +2. The time now is 18:30.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.