HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Services aren't reachable remotely (http://www.howtoforge.com/forums/showthread.php?t=42502)

bschultz 8th January 2010 21:45

Services aren't reachable remotely
 
I'm having a problem with others being able to reach my server remotely...web, mail, ftp, ssh etc are all seeing the same problems.

If I type in my domain name into my browser from work, I can't get to my website. I also can't connect to email or ftp. If I type in my IP address into the browser, I see the "It works" Apache page.

I can connect with Putty to my server remotely...but I can't use WINSCP...it hangs on "reading remote directory".

Others (on other IPS's) are also not able to connect to my websites. I am receiving emails...but I can't check my email remotely.

I am running iptables and fail2ban (base install on both)...but don't see anything in the logs that is telling me that anything is wrong. In fact...this is the only error in the syslog:

Quote:

Jan 8 06:27:13 mail postfix/smtpd[8744]: SSL_accept error from loc6.paulbunyan.net[209.191.199.141]: -1
Jan 8 06:27:13 mail postfix/smtpd[8744]: lost connection after STARTTLS from loc6.paulbunyan.net[209.191.199.141]
Jan 8 06:27:13 mail postfix/smtpd[8744]: disconnect from loc6.paulbunyan.net[209.191.199.141]
paulbunyan.net is my ISP...but I don't know who is on that IP address.

Any ideas what might be going on here? I should add that I'm running Etch using a combination of Falko tutorials. The email portion is Mysql virtual users. The system has been running great for almost a year, and I haven't made any changes to anything recently.

Thanks.

Brian

falko 9th January 2010 11:32

Does it work when you switch off the firewall and fail2ban (for testing purposes)?

bschultz 9th January 2010 17:22

Thanks Falko...shutting off fail2ban and iptables made no difference.

bschultz 9th January 2010 23:37

I'm at a remote location right now on wifi...I can't reach my server (on any service or program)...but a guy sitting right next to me (on the same wifi) can!

This is getting confusing!

falko 10th January 2010 17:38

Is it maybe a problem with the firewall on your client PC?

bschultz 10th January 2010 20:12

Multiple people on multiple networks are having the same problem reaching the server (Apache). I'm the only one that connects to SSH or FTP, so I don't know how widespread that problem is. I do know that I can't connect via SSH from my office.

Could this be a DNS issue (DNS is done with GoDaddy), or some other routing (my router port forwards to my server) issue?

bschultz 11th January 2010 02:35

Requests are coming into the server...here's a part of the Apache log when I tried to logon to my server from my work computer...

Quote:

www.domain.com:80 REMOTE-IP - - [10/Jan/2010:19:24:37 -0600] "GET /blogs/index.php HTTP/1.1" 200 11035 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7"
It's been 10 minutes since I typed in the address for that domain...and still no page loaded in the browser. In fact, Firefox still says it's loading the page. I've run a speed test to see what my upload speed is...and it's at 5-8 megs per second...so that should be OK.

The above line is the only sign of activitiy in the log...while most requests will show that several images and such have been requested.

Thanks for the help!

bschultz 11th January 2010 05:02

I'm also now seeing this

Quote:

conversation with domain.com[IP address] timed out while sending message body
in the mail logs while sending...and emails aren't being received...by some people, while others are being delivered.

falko 11th January 2010 14:14

You should check your domain here: www.intodns.com

bschultz 11th January 2010 23:30

And things are solved...my ISP replaced their router that served my location...and everything is once again reachable.

Thanks, Falko!


All times are GMT +2. The time now is 05:12.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.