HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Send email with Sympatico.ca (http://www.howtoforge.com/forums/showthread.php?t=4235)

databox 11th May 2006 17:30

Send email with Sympatico.ca
 
I try to send email with my ISP sympatico.ca but port 25 is filtered.
Does anybody use ispconfig with Bell Canada ?
I know i need to use their SMTPH.sympatico.ca as a relayhost but the SASL and TLS fail when I send a email tought postfix.

Any ideas or links are welcome.

Norman 11th May 2006 17:36

Do I understand this correctly, your postfix is configured with relayhost= smtph.sympatico.ca ?

And now you're having trouble sending through their SMTP since you arent authenticated?

databox 11th May 2006 18:09

smtph.sympatico.ca
 
Yes exactly. authentification fails when i try to send email with my server (centos 4.3 with ISPconfig)

falko 11th May 2006 18:11

Have a look here: http://www.howtoforge.com/forums/sho...07&postcount=2

databox 11th May 2006 21:59

This is my /etc/postfix/main.cf

************************************************
readme_directory = /usr/share/doc/postfix-2.1.5/README_FILES
smtpd_sasl_local_domain =
mydestination = /etc/postfix/local-host-names
smtpd_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtpd_sasl_security_options =
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = yes
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
mailbox_command =
virtual_maps = hash:/etc/postfix/virtusertable
***************************************

And this is the maillog when i try to send an email with webmail squirrelmail :

************************************
May 11 15:08:02 idserver postfix/smtp[20259]: setting up TLS connection to smtphm.sympatico.ca
May 11 15:08:02 idserver postfix/smtp[20259]: verify error:num=20:unable to get local issuer certificate
May 11 15:08:02 idserver postfix/smtp[20259]: verify error:num=27:certificate not trusted
May 11 15:08:02 idserver postfix/smtp[20259]: verify error:num=21:unable to verify the first certificate
May 11 15:08:02 idserver postfix/smtp[20259]: Peer certficate could not be verified
May 11 15:08:02 idserver postfix/smtp[20259]: 3E895474546: to=<address@domain.net>, relay=smtphm.sympatico.ca[65.54.191.190], delay=1, status=bounced (host smtphm.sympatico.ca[65.54.191.190] said: 550 5.7.3 Requested action aborted; user not authenticated (in reply to MAIL FROM command))
May 11 15:08:02 idserver postfix/smtp[20259]: warning: Read failed in network_biopair_interop with errno=0: num_read=0, want_read=5
May 11 15:08:02 idserver postfix/cleanup[20258]: 83791474548: message-id=<20060511190802.83791474548@idserver.myserver.c om>
May 11 15:08:02 idserver postfix/qmgr[20237]: 83791474548: from=<>, size=3451, nrcpt=1 (queue active)
May 11 15:08:02 idserver postfix/qmgr[20237]: 3E895474546: removed
**********************************

I follow your instructions but I have the same problem.

falko 12th May 2006 11:07

I don't see
Code:

relayhost= smtph.sympatico.ca
in your /etc/postfix/main.cf. Please add it and restart Postfix.


All times are GMT +2. The time now is 03:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.