HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Technical (http://www.howtoforge.com/forums/forumdisplay.php?f=8)
-   -   tar backup (multivolume) error message (http://www.howtoforge.com/forums/showthread.php?t=42340)

kaza 1st January 2010 20:29

tar backup (multivolume) error message
 
Hello,

I attempted to perform a full backup using "tar" and a SCSI tape drive.
The command issued (as a root) was:

tar -cvMPf /dev/st0 --volno-file /root/backup/backup_vol_nums /*

It started OK but after some time (I guess, when the first tape had
been filled up) I've got the error message:

tar: /dev/st0: Cannot close: Input/output error
Prepare volume #2 for `/dev/st0' and hit return:

I attempted to replace the tape and got the error message:

tar: /dev/st0: Warning: Cannot open: No such device or address
Prepare volume #2 for `/dev/st0' and hit return:

From that point and on, the device "/dev/st0" behaved busy
and even the "shutdown" didn't worked - apparently
the system waited until everything had been properly closed
while this device remained opened so I finally had to brutally
power down the system. Reading about SCSI tape device names
I saw that there are few names for the same tape:

/dev/st0 for mode 0
/dev/st0l for mode 1
/dev/st0m for mode 2
/dev/st0a for mode 3

Did I used the correct device name for multi-volume backup with tar?
What is the difference between different modes of accessing the SCSI tape?
Any ideas as to what causes the error message?


TIA,
kaza.

kaza 15th January 2010 14:16

Anyone has/had such problem?

falko 16th January 2010 15:18

Unfortunately I have no experience with tape drives... :(


All times are GMT +2. The time now is 18:58.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.