HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Courier, Postfix, Squirrelmail Mysql How-To (http://www.howtoforge.com/forums/showthread.php?t=42328)

kresser 1st January 2010 12:53

Courier, Postfix, Squirrelmail Mysql How-To
 
Ok, i followed this tutorial to the "T", http://www.howtoforge.com/virtual-us...l-debian-lenny. I am not able to login to the mailboxes with squirrelmail, it says "connection dropped by imap server" I used the whole address as a login just like it said to do. I can sucessfully authenticate with outlook express but it throws an error that say's arealreason.com/support, no such file or directory. i can telnet into it remotely but when i type ehlo messiah.arealreason.com it just keeps showing all the 250 lines and wont let me generate a message. from what i saw on the comments on the tutorial and googling there are many other people with this problem, however i found no solutions. This is fresh work and i have not touched any config files since finishing the tutorial, so if anyone has this solution it would be greatly appreciated. This server needs to go into production in a few days so let me know. Thx -Rick

kresser 1st January 2010 14:10

Also...
 
This is also coming up in mail logs.

Jan 1 07:33:17 messiah postfix/smtp[46100]: 9331B6E68D87: to=<jim@arealreason.com>, relay=none, delay=0.16, delays=0.15/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

Jan 1 07:33:47 messiah imapd: Connection, ip=[::ffff:99.196.176.7]
Jan 1 07:33:51 messiah imapd: chdir arealreason.com/support/: No such file or directory

Jan 1 07:39:04 messiah postfix/smtp[55258]: 879876E68D82: to=<root@arealreason.com>, orig_to=<root>, relay=none, delay=4739, delays=4739/0.28/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

Jan 1 08:02:24 messiah postfix/scache[28585]: statistics: start interval Jan 1 07:59:04
Jan 1 08:02:24 messiah postfix/scache[28585]: statistics: domain lookup hits=0 miss=1 success=0%
Jan 1 08:02:24 messiah postfix/scache[28585]: statistics: address lookup hits=0 miss=1 success=0%
:mad:

kresser 2nd January 2010 06:13

Some updates...
 
I saw where several other people were having this issue and one person went in and manually created his domain folder like /home/vmail/domain/username. I did this the same and it got both of us one step farther. I finally figured out this is a mail folder and permission issue. I can successfuly connect and authenticate with the server with squirrelmail and outlook, squirrelmail gives the imap connection dropped after authenticating and oe says mydomain/account is not there. well i manually created the domain and account folder chowned with vmail properties and i get one step farther but still more folder errors. squirrelmail now shows the 2 frames after login but this error shows in each frame:

ERROR:
ERROR: Could not complete request.
Query: SELECT "INBOX"
Reason Given: Unable to open this mailbox.

I know alot of people had this problem and i would be so grateful if someone could help me fix the folder problems and direct me in the right direction as to fix them being automatically created. the sending an email to the box didnt work.

falko 2nd January 2010 15:18

Quote:

Originally Posted by kresser (Post 214934)
This is also coming up in mail logs.

Jan 1 07:33:17 messiah postfix/smtp[46100]: 9331B6E68D87: to=<jim@arealreason.com>, relay=none, delay=0.16, delays=0.15/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

It seems as if amavisd isn't running. Please restart it and send the welcome mail again.

kresser 3rd January 2010 00:41

you were right about amavis, still wont start...
 
Ran this:

messiah:~# /etc/init.d/amavis start
Starting amavisd: amavisd-new.
messiah:~#

Didn't know if there was supposed to be more information on loading than what it gave.

Also even after i give it the start sig, if i send restart it says this:

messiah:~# /etc/init.d/amavis restart
Stopping amavisd: (not running).
Starting amavisd: amavisd-new.

Still says "connection refused" in logs.

I need some guidance on where to start looking for the problem...

Thx in advance.

kresser 3rd January 2010 03:14

ok need help.
 
I googled amavis wont start, and found out it does that right out of the box now. I guess a package problem.

So... i decided to just try without it. I commented out the lines that was added to main.cf and master.cf. Restarted the server, now when i send an email i get this error msg:

Jan 3 04:56:20 messiah postfix/virtual[14245]: ECDA26E68DE0: to=<support@arealreason.com>, relay=virtual, delay=0.18, delays=0.1/0/0/0.08, dsn=5.1.1, status=bounced (unknown user: "support@arealreason.com")

and for the first time i am getting messages back from from my mail server saying message undeliverable....

hmm.

falko 3rd January 2010 17:31

Does support@arealreason.com exist in your database?

kresser 3rd January 2010 17:53

yup its in the sql database and oe will authenticate with it when i manually add the folder's /home/vmail/arealreason.com and /home/vmail/arealreason.com/support and chown then with vmail:vmail it keeps throwing folder errors.
Without the folders it says /arealreason.com/support No such file or directory.
But if i comment out the lines for postfix to use amavis and apt-get remove amavsd-new and reboot the vps. when i send an email from an outside account it says support is an unknown user. So...I'm going to use a debian lenny installation to recreate the problem at home on one of my esxi servers at home to continue figuring out how to fix this. but so far the ONLY TUTORIAL i have got working on lenny is at debianadmin.com but it uses standard system users and i need a sql server up that will easily support thousands of email accounts. I've tried the ispconfig 3 tutorial and many others on lenny that have all failed, a few i know now because of amavis. So i think my only option is to try etch on the vps because i need a working mail server right now. The weird thing is that with the whole setup done on lenny as you described in your tutorial it will store all the incoming messages on the mail server its just amavis wont run to let it make the folders after an email is recieved. So i want to leave this thread open to try to resolve the problem on one of my vm's so other people will know after the problem is resolved. As google returned ALOT of people with my same problem. Thx for your support falko.

falko 4th January 2010 15:00

I know that the tutorial is working, so there must be something wrong on your server. What kind of virtualization technique do you use (OpenVZ/Virtuozzo, KVM, Xen, VMware, etc.)?

kresser 4th January 2010 18:14

Problems...
 
Well, i have been using a vps that uses a veportal management page, i don't know what underlying software they use for virtualization. I use VMware esxi one my 1u's in my lab, i always have vmware tools installed on the vm's. I have discovered a few problems that add to the issue's. For the record if anyone that reads this doesn't know, mysql has problems using some special characters in the mysql passwords. I had a $ in my passwords which caused root@localhost acces denied, but im having tons of problems on every tutorial i've done with amavis. It seems it never wants to start up. I have used quite a few of your tutorials which are very well put together might i add. I just switched over from using microsoft 1 year ago, so i guess you could say i'm a little new but i've been into ubuntu debian suse and openbsd head deep since then. Is amavis a REQUIREMENT to use the ispconfig 3 tutorial? also the vps is amd64 hardware, and my lab servers are intel 64bit running esxi 64 bit with mostly 32bit vm's. I trust your tutorials work, it's just working out my own bugs thats a headache. Once again, Falko thank you for your support.


All times are GMT +2. The time now is 17:56.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.