HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Fixing open_basedir restriction (http://www.howtoforge.com/forums/showthread.php?t=42222)

runbuck 28th December 2009 15:48

Fixing open_basedir restriction
 
So, I switched to ISPconfig3 over the weekend. All good. Basic sites moved fine. However, when I tried to run the wordpress install on one site (via moving the wordpress install files into a sub-dir I created off that sites web root called "Blog") I got this error on the first step:
Quote:

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/var/www/clients/client1/web3/web/wp-config.php) is not within the allowed path(s): (/var/www/clients/client1/web3) in /var/www/clients/client1/web3/web/wp-load.php on line 27
I got similar error on subsequent steps. Basically, ispconfig3's php safe mode is blocking I assume. However there is no checkbox like in ispconfig2 to shut it off for that site.

I googled around and saw comments from Till that such errors could be fixed by editing the vhost.conf.master and adding the directory to the open_bind statements in the file (2 places). So I added this:
Code:

php_admin_value open_basedir /var/www/clients/client1/web3/web/blog
After the two open_bind statements already in that file. Making it look like this (first instance shown):

Quote:

<tmpl_if name='security_level' op='==' value='20'>
php_admin_value open_basedir <tmpl_var name='document_root'>/web:<tmpl_var name='document_root'>/tmp:/usr/share/php5
#buck - added for wp
php_admin_value open_basedir /var/www/clients/client1/web3/web/blog
</tmpl_if>
On trying the install page again (after stop/starting apache and resaving the site in ispconfig to regen the site specific vhosts - which i assume come from the vhosts.conf.master file.) i got nothing - same open_bind restriction error.

Did I edit/add the open_bind statement incorrectly? If not, is there a better way to install wordpress for a site running on ispconfig3? I assume you should move the files to a sub-dir of the site /web directory (as that is how it used to work).

Any thoughts appreciated.

till 28th December 2009 19:56

All files of a website have to be licated in the web directory of this site. I run many wordpress installs, never had a problem with open_basedir when you install it into the web dir or a subdirectory of the web dir. So I never had to adjust the open_basedir path. You should check where you installed the files and copy them to a correct directory inside the web dir or the web dir itself.

runbuck 28th December 2009 20:57

DOH! Reinstall worked
 
Till, thanks for thought. Fixed it.

I had downloaded to the server and then moved the files (mv) to a sub-directory in the /web. That was the way that had it all whacked (not sure why).

When I did it the second time, I downloaded to a win7 client and FTP'd to the web sub-dir for the blog. Then it worked.

Strange.

Regardless, your point that it worked got me to try again. Thanks. And I learned wayyyyy to much about open_basedir as I tried to resolve it the hard (stupid/wrong) way.:)


All times are GMT +2. The time now is 18:12.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.