HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Groups totally gone. (http://www.howtoforge.com/forums/showthread.php?t=42005)

untg 19th December 2009 14:07

Groups totally gone.
 
I've installed a new server and it seems to be working ok, until I has a look at /etc/group and there is only one listing,
client1:x:100:www-data
Is that normal for ispconfig3, I would have thought /etc/group had more listings?

I just installed apt-get install ubuntu-desktop so I don't know if that would have anything to do with it.

Is someone able to sent me their newly installed ISPConfig3's group file? I'm sure mine has something seriously wrong with (I only installed the server two days ago).

Thanks

falko 20th December 2009 13:23

Do you have a backup of /etc/group? What's the output of
Code:

ls -l /etc/group*
?

untg 20th December 2009 23:45

I've reinstalled since then but i'll remember to backup the groups file and passwd file.
Just wondering if there is any reason why that would happen or just a freak accident of some package.

untg 21st December 2009 04:08

Just in case anyone else has this problem, I just noticed that it looks like backups are kept in /var/backups/ automatically by debian/ubuntu.

So I could have probably just restored /etc/group from /var/backups.

oh well, next time :)

till 21st December 2009 08:38

ISPConfig 3 does not manage the /etc/group file directly, it uses only the groupadd command from ubuntu to add groups, so its very unlikely that this has been caused by ispconfig.


All times are GMT +2. The time now is 04:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.