HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   already in use: make_sock: could not bind to address [::]:80 (http://www.howtoforge.com/forums/showthread.php?t=41494)

paxpacis 1st December 2009 18:15

already in use: make_sock: could not bind to address [::]:80
 
Yesterday, we copied the wrong ssl request in the ssl request box, this was because ispconfig3 defaults to the url given and ispconfig2 automatically changed it to www.domain.xxx.

This caused the whole ispconfig server to stop working. The only thing after a apache restart was [fail] no loging in the logfiles etc.
I disabled the faulty website with a2dissite and after 2 restarts ispconfig was up and running again.
But now every time I do a restart the following is happening:

root@www:/etc/apache2/ssl# /etc/init.d/apache2 restart
* Restarting web server apache2 (98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[fail]
root@www:/etc/apache2/ssl# /etc/init.d/apache2 restart
* Restarting web server apache2 httpd (no pid file) not running
[ OK ]

So first time restart does not work and second time we are back..

Anybody a clue why this is happening?..

till 2nd December 2009 09:20

There must be some hanging apache processes. Run:

killall apache2
/etc/init.d/apache2 restart

paxpacis 2nd December 2009 12:43

Hi Till,

thank you, it worked..


All times are GMT +2. The time now is 08:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.