HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Tips/Tricks/Mods (http://www.howtoforge.com/forums/forumdisplay.php?f=29)
-   -   Hints installing ISPc3 on a vhost / virtuahost at s4y (http://www.howtoforge.com/forums/showthread.php?t=41000)

pjo 15th November 2009 11:24

Hints installing ISPc3 on a vhost / virtuahost at s4y
 
Hi,

i just installed ISPCONFIG 3 (3.0.1.5) on a vhost (server4you.de) with debian etch standard installation according to the documentation.

As this is a virtual host it might be the reason why some things didn't work as expected. So I decided to write a few hints how I solved it.

1. the pure-ftp problem.

issue: pure-ftpd not starting - syslog: [ERROR] Unable to switch capabilities : Operation not permitted

solved by: compiling pure-ftpd without capabilities.
I know there are ready compiled deb i386 packets to download anywhere, but I needed it for amd64. So I compiled by myself.
You can download it here: http://pjo.de/pure.html
Install it with
Code:

dpkg -i paketname.deb
2. I don't know why, but SMTP, let's say Authentication SASL didnt work for me. I noticed that there were some differences in the /etc/default/saslauthd
So I did:
vi /etc/default/saslauthd

and changed these parameters:

Code:

MECHANISMS="pam"
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"

3. My mailrules didn't work
I tried many things. At the end this resolved the problem:
I comented out that optin in postfix main.cf:

Code:

receive_override_options = no_address_mappings
So perhaps some have similar problems, and this might help.

By the way I migrated from ISPc2 to a ISPc3 system.
A smooth way to transfer the web data from one to another server was lftp(apt-get install lftp):

Code:

lftp -u web12_admin,ftppassword -e "set ftp:list-options "-a" && mirror --allow-chown /web /var/www/clients/client1/web1/web && bye" oldserver.de
Using that command I moved successfully some joomla and wordpress sites.

Of course additinally you have to export/import the SQL tables...

Regards,

Jonny

ispconfigMan 6th December 2009 08:27

VPS Hosting
 
I am hosting with RapidSwitch www.rapidswitch.com using a Debian 4 VPS on their starter package which is super cheap at 7 per month. I setup ISPConfig 3 with out any probs...apart from a postfix problem which i am trying to resolve. But no major issues.

pureskills 9th December 2009 22:18

hello

nice thread I just installed ISPconfig 3 on my s4y vserver

But know i try to create a couple of subdomains.
I created the subs in ISP config and added some dns A records but i still don'T know where i have to put the content.

Do i need to create a new folder? And is it important that i set a subdomain DNS A record in the s4y powerpanel, too?

thanks for you help


All times are GMT +2. The time now is 13:28.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.