HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Can't connect externally (http://www.howtoforge.com/forums/showthread.php?t=40628)

beezer1424 2nd November 2009 18:28

Can't connect externally
 
I am having issues with my debian and ispconfig3 setup. I use namecheap to register my domain names.

DNS:

I believe I have it setup although 2 different threads had different DNS Record entries for Name and mail servers, please direct me:
Should my zone entry for name and mail servers be domain.com. (with dot)
and the nameserver hostname ns1.domain.com (without dot).

FTP:
where is the FTP conf file? i am not able to login to the ftp server and I haven't tried passive

Website:
I can view the "it works" screen only when typing http://10.0.1.80 (internal address) of webserver, I am not able to access it from any external site. I am able to access ISP config by typing either the public ip address of my router or http://www.mydomain.com:8080. I have forwarded port 80 to the webserver as well as 8080, 443, 53 and 21.

Email:
I am only able to logon to webmail from internal network

falko 3rd November 2009 14:42

Quote:

Originally Posted by beezer1424 (Post 209387)
DNS:

I believe I have it setup although 2 different threads had different DNS Record entries for Name and mail servers, please direct me:
Should my zone entry for name and mail servers be domain.com. (with dot)
and the nameserver hostname ns1.domain.com (without dot).

If you use the full hostname, you must always use a dot at the end. If you use just a part of the hostname (such as www or mail), you must not use a dot.

Quote:

Originally Posted by beezer1424 (Post 209387)
FTP:
where is the FTP conf file? i am not able to login to the ftp server and I haven't tried passive

I believe the configuration files are in the /etc/pure-ftpd directory.

Quote:

Originally Posted by beezer1424 (Post 209387)
Email:
I am only able to logon to webmail from internal network

Any errors in your mail log?

beezer1424 3rd November 2009 17:40

Responses
 
DNS: thanks for clearing that up.

FTP: that is where I thought it would be there is no file, but a conf directory. In the conf directory there are no pure-ftpd.conf files.

webmail: here is the log info

Nov 3 10:55:01 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
Nov 3 10:55:01 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Nov 3 10:55:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
Nov 3 10:55:01 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
Nov 3 10:55:01 server1 postfix/smtpd[19670]: connect from localhost.localdomain[127.0.0.1]
Nov 3 10:55:01 server1 postfix/smtpd[19670]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Nov 3 10:55:01 server1 postfix/smtpd[19670]: disconnect from localhost.localdomain[127.0.0.1]

there is nothing in the mail-err or mail-war logs

falko 4th November 2009 14:48

Did you use this guide to set up your system? http://www.howtoforge.com/perfect-se...nny-ispconfig3

beezer1424 4th November 2009 18:40

Guide
 
The only thing different I did during the install was use debian 5.0.3, ISPCONFIG 3.0.1.6, and jailkit 2.10. I am behind a mikrotik router/nat/firewall, just incase there is anything special I need to do to forward ports although i have been using my sip server for the last year just fine! I will redo the server with 5.0.0 if necessary. I would try passive FTP, but I can't find the config file, does anyone know where that file should be located?

beezer1424 5th November 2009 05:12

reinstalled
 
Falko,

I reinstalled, but with centOS 5.4 and ISPCONFIG3. It worked first try. Thanks for your help.


All times are GMT +2. The time now is 20:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.