HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ispconfig 3 mydns master to ispconfig 2 bind slave (http://www.howtoforge.com/forums/showthread.php?t=40571)

mooseman 31st October 2009 15:22

ispconfig 3 mydns master to ispconfig 2 bind slave
 
Hi,

I attempted to create a "master" dns server in ISPconfig 3 using mydns and have it replicate to my ispconfig 2 bind dns. Both servers are being NATed behind respective firewalls.

I updated the mydns.conf with the following options:

allow-axfr = yes
allow-update = yes
notify-enabled = yes
notify-source = (public NATed IP of mydns master)

I created the zone on the master ispconfig 3 server (mydns) and created a slave zone on the ispconfig 2 (bind 9) server pointing to the master.

The initial axfr goes through but any updates to the zone are not transferred with the following error in the log:

I receive the following in the syslog of the ispconfig 2 bind server:

Oct 31 10:03:30 (server) named[(PID)]: client (public.IP.of.mydns)#47075: received notify for zone '(domain).com'
Oct 31 10:03:30 (server) named[(PID)]: zone .com/IN: Transfer started.
Oct 31 10:03:30 (server) named[(PID)]: transfer of '(domain).com/IN' from (public.IP.of.mydns)#53: connected using (private.IP.of.mydns)#35684
Oct 31 10:03:30 (server) named[(PID)]: transfer of '(domain).com/IN' from (public.IP.of.mydns)#53: failed while receiving responses: end of file
Oct 31 10:03:30 (server) named[(PID)]: transfer of '(domain).com/IN' from (public.IP.of.mydns)#53: end of transfer


Is the "failed while receiving responses: end of file" occurring because of the private ip being sent?? is "notify-source = " config option of mydns supposed to fix that?

Any help would be appreciated.

Thanks,

till 1st November 2009 11:12

Please try to disable ixfr in bind on the slave:

http://www.howtoforge.com/forums/showthread.php?t=37727

mooseman 2nd November 2009 01:11

That Worked!...

I also should be leaving out the "notify-source = xxx" statement in the mydns.conf

Great, Thanks!

--
MoOSeMaN


All times are GMT +2. The time now is 09:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.