HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Stuck in Jobqueue (http://www.howtoforge.com/forums/showthread.php?t=40458)

chris4brown 27th October 2009 15:45

Stuck in Jobqueue
 
We are running a multiserver setup and after running some updates we can no longer add sites, databases, or anything to the system.

This is the only thing the system logs show once in debug mode. This is showing on all the servers.

2009-10-27 10:40 odin.mpl.com Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2009-10-27 10:40 odin.mpl.com Debug No Updated records found, starting only the core.
2009-10-27 10:40 odin.mpl.com Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2009-10-27 10:39 odin.mpl.com Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2009-10-27 10:39 odin.mpl.com Debug No Updated records found, starting only the core.
2009-10-27 10:39 odin.mpl.com Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2009-10-27 10:38 odin.mpl.com Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2009-10-27 10:38 odin.mpl.com Debug No Updated records found, starting only the core.
2009-10-27 10:38 odin.mpl.com Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2009-10-27 10:37 odin.mpl.com Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2009-10-27 10:37 odin.mpl.com Debug No Updated records found, starting only the core.
2009-10-27 10:37 odin.mpl.com Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2009-10-27 10:36 odin.mpl.com Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2009-10-27 10:36 odin.mpl.com Debug No Updated records found, starting only the core.
2009-10-27 10:36 odin.mpl.com Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

It is showing to updated records but the jobqueue is full. Can someone please help. Thanks

I forgot to mention we are using Ubuntu 9.04 and ISPConfig 3.0.1.6

till 27th October 2009 18:50

Looks as if you enabled debugging on the wrong server. Please enable debugging on the slave server and check the monitor again.

chris4brown 27th October 2009 18:55

/usr/local/ispconfig/server/server.sh27.10.2009-13:54 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
27.10.2009-13:54 - DEBUG - No Updated records found, starting only the core.
27.10.2009-13:54 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.


This is what I am getting on both of the slave servers. Any ideas? It should be finding records because the queue is full. What else could it be?

till 27th October 2009 19:01

Please check the jobqueue on the master server if the server_id of the records which are stored (in the sys_datalog) table is identical to the server_id in the /usr/local/ispconfig/server/lib/config.inc.php file on the slave(s). Also check if you are able to login from the slave to the master mysql db with the mysql master username and password stored in this file.

chris4brown 27th October 2009 19:15

Should this line be this way on the slave

$conf["dbmaster_host"] = 'localhost';

Shouldn't this be the address for the master server?

till 27th October 2009 19:17

Yes, this should be the hostname of the master server.

chris4brown 27th October 2009 19:23

Everything works again!
When I ran the update on the slave servers I ran ispconfig_update.sh Did this mess up the configuration file or what could have done this?

till 27th October 2009 19:27

The updater should have asked you for the servername of the master server during the update (this is new in the 3.0.1.6 updater). Did you remeber if you answered this with localhost or the master server name?

The exact question was "MySQL master server hostname".

chris4brown 27th October 2009 19:34

I really don't remember, that was a week ago. I really do appreciate all the help. Thank you so much!


All times are GMT +2. The time now is 10:58.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.