HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Spamsnake - Mail Transport Unavailable Issue (http://www.howtoforge.com/forums/showthread.php?t=40401)

frogman 25th October 2009 22:23

Spamsnake - Mail Transport Unavailable Issue
 
I believe I have followed The Perfect SpamSnake - Ubuntu Jaunty Jackalope -Howto to the letter...

I am down to what I hope is my final challenge:

Incoming messages are getting stuck after content scanning in the postfix queue. When forcing a flush on the queue, I get the following in the log:

Oct 25 17:16:55 spamsnake postfix/qmgr[4015]: 12361BE9BB: from=<sender@domain.tld>, size=2853, nrcpt=1 (queue active)
Oct 25 17:16:55 spamsnake postfix/qmgr[4015]: warning: connect to transport SMTP: No such file or directory
Oct 25 17:16:55 spamsnake postfix/error[4439]: 12361BE9BB: to=<user@transportdomain.tld>, relay=none, delay=8858, delays=8858/0.03/0/0.02, dsn=4.3.0, status=deferred (mail transport unavailable)

transportdomain.tld refers to a single transport domain that I have defined.

Is anyone else experiencing this issue? Any thoughts?

Tyiell 26th October 2009 11:03

I feel your pain - I have a similar problem (my thread). Does your mailwatch front end show any stats on what its stopping/scanning/etc?

Paul

frogman 26th October 2009 13:14

Paul,

Thanks for the reply. Mine is actually making it through the scanning/scoring, etc. all the way to the Outgoing queue. Looks like it is trying to get out, then I get the SMTP unavailable message.

I have also installed Webmin to more easily manage Postfix and can see the messages stuck in there. Forcing a release (postqueue -f) generates the same error.

Other mail, like from the cron jobs out to another Internet mailbox are working, which makes this even more strange.

I had previously followed the 8.04 Ubuntu Howto which had several issues, but I did get that one to release the mail. My next step here is to go through the configuration settings from that one and see what is different...

-fm

Tyiell 26th October 2009 13:41

I'll not be much help then - I'll probably get the problem you're having if I ever fix my own!! It's driving me mad at the moment but I'll keep you updated if mine starts behaving :)

Good luck!

Rocky 26th October 2009 16:34

Frogman,

Does your line in master.cf match the following?
smtp inet n - - - - smtpd

frogman 26th October 2009 19:45

Rocky,

yes, that is exactly what it says in master.cf

smtp inet n - - - - smtpd

Rocky 27th October 2009 01:55

Ok, did you uninstall apparmor?

Also, recreate your transport file for posfix. Make sure to postmap it and restart postfix when finished.

frogman 27th October 2009 02:30

Rocky,

Thanks for the reply... I have recreated transport and postmap'd it. And re-executed the commands to stop apparmor and remove it from init.d - NO CHANGE, unfortunately.

BUT, I stopped short of an aptitude remove because it says it will REMOVE a bunch of other stuff.

root@spamsnake:~# aptitude remove apparmor apparmor-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages will be REMOVED:
clamav{u} clamav-base{u} clamav-daemon{u} clamav-freshclam{u}
libclamav6{u} libconvert-binhex-perl{u} libconvert-tnef-perl{u}
libdbd-sqlite3-perl{u} liberror-perl{u} libfilesys-df-perl{u}
libio-socket-inet6-perl{u} libio-stringy-perl{u} libmail-spf-perl{u}
libmime-perl{u} libmime-tools-perl{u} libnet-cidr-lite-perl{u}
libnet-cidr-perl{u} libnetaddr-ip-perl{u} libole-storage-lite-perl{u}
libsocket6-perl{u} libsys-hostname-long-perl{u} libsys-syslog-perl{u}
libtommath0{u} re2c{u} spamassassin{u} spamc{u} tnef{u}
0 packages upgraded, 0 newly installed, 27 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 33.7MB will be freed.
Do you want to continue? [Y/n/?]

I said No at this point. Should I let it remove these items? I figured unloading the service and removing it from init.d would suffice and I did not want to break anything else... Thoughts?

One item that I do not think is relevant, but anyway... One step (16.4) that doesn't work for me is when trying to manually start mailscanner at the command prompt. It seems as though the /opt/MailScanner...etc.. is not in the path as the original apt-get install of Mailscanner is. But, it is started by the cron job check_mailscanner or I start it from within /opt/etc/MailScanner/bin... I also created a ln -s from etc/MailScanner to /opt/MailScanner

I appreciate yours and anyone else's help!!

-fm

Tyiell 27th October 2009 13:36

Just to let you know that having solved a few of my problems, I am now (as predicted) stuck with the exact problem you have!! Mail Transport Unavailable. I have gone thorugh the same steps you have in this thread with the same results, so please keep me informed if you fix it!!!! I'll obviously do the same if I get lucky :)

Many thanks,

Paul

Rocky 27th October 2009 19:23

Hey,

Please post your transport, relay and master.cf file.


All times are GMT +2. The time now is 02:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.