HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   The autoresponse is not working with ISPConfig 3.0.1.4 (http://www.howtoforge.com/forums/showthread.php?t=40035)

voltron81 12th October 2009 18:46

The autoresponse is not working with ISPConfig 3.0.1.4
 
Hi to everybody.
I'm almost finish my configuration and I was trying the autoresponder feature.
The system in a Debian with ISPConfig 3.0.1.4.
I create domains and email and it's just working fine.
When I try to setup an autoresponse for one email address, in ISPConfig I write the message and I active the autorespond.
I wait some minutes (cron time) and I try to send an email to that address(from another email of the same domain for example).
From the log I can see that the email is correctly sent, and in fact I'll receive this email to the email address, but the sender doen't receive the autoresponder message.
I checked in /var/vmail/mailfilters/domain/email/ and i have the 2 files .autoresponder and .vacation.msg
The permissions for the whole /mailfilters file and for the .mailfilter file are 600.

There is something that I'm forgotting?
Thanks
Michele

voltron81 12th October 2009 18:57

Reading the .mailfilter file, I can see:
Code:

# Check if the user has a autoresponder enabled

`test -f /var/vmail/mailfilters/$HOST/$USER/.autoresponder`
if ( $RETURNCODE == 0 )
{
  include "/var/vmail/mailfilters/$HOST/$USER/.autoresponder"
}

So it's testing if I setup an autoresponder for that email.
If I'm going to /var/vmail/mailfilters/$HOST/$USER/.autoresponder I can see the the file exist...
What's wrong?
Thanks
MiK

voltron81 13th October 2009 11:17

Any idea?
:)
Thanks
MiK

damir 13th October 2009 11:33

I just tested it on my ISPConfig 3.0.1.4 system and it works as it should. Im using Debian Lenny 5.0.3. So it must be something with your installation.

When you enable autorespnder, did you check teh Autoresponder box? You probably did that but im asking in case you missed it :)

voltron81 13th October 2009 14:03

Probably the error is because the feature autoreply is using sendmail to send the reply, and I'm running the server in a local network for the moment...
Thanks
Michele


All times are GMT +2. The time now is 18:07.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.