HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   DBI version 1.43 required--this is only version 1.40 at /usr/sbin/amavisd line 13364 (http://www.howtoforge.com/forums/showthread.php?t=39821)

thabangk 2nd October 2009 14:06

DBI version 1.43 required--this is only version 1.40 at /usr/sbin/amavisd line 13364
 
Hi

I can't get to restart the postfix.i get this error and all my packages i installed them using yum what may be wrong?I'm using centos 4.7

Starting Mail Virus Scanner (amavisd): DBI version 1.43 required--this is only version 1.40 at /usr/sbin/amavisd line 13364.
[FAILED]

This is the error i got in the maillog:

Oct 2 14:03:02 server1 amavis[6441]: starting. /usr/sbin/amavisd at server1.example.com amavisd-new-2.6.4 (20090625), Unicode aware, LANG="en_US.UTF-8"
Oct 2 14:03:02 server1 amavis[6441]: Perl version 5.008005

and in the messages log i got this:

unuser: DBI version 1.43 required--this is only version 1.40 at /usr/sbin/amavisd line 13364

Please help!!!!!!!!!!!

falko 3rd October 2009 16:37

You must install the newest DBI Perl module. We do this on the Perl shell:

Code:

perl -MCPAN -e shell
Once you are on the Perl shell, you can install DBI as follows:

Code:

install DBI
Type

Code:

q
afterwards to leave the Perl shell.

thabangk 5th October 2009 09:53

Hi

Just got this when running install DBI

*** Your LANG environment variable is set to 'en_US.UTF-8'
*** This may cause problems for some perl installations.
*** If you get test failures, please try again with LANG unset.
*** If that then works, please email dbi-dev@perl.org with details
*** including the output of 'perl -V'

and at the end got this:

Writing Makefile for DBI
make: *** No rule to make target `[]'. Stop.
/usr/bin/make [] -- NOT OK
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible

And again in the maillog i got this after trying to restart the amavisd service:
Oct 5 10:21:25 server1 amavis[6933]: starting. /usr/sbin/amavisd at server1.example.com amavisd-new-2.6.4 (20090625), Unicode aware, LANG="en_US.UTF-8"
Oct 5 10:21:25 server1 amavis[6933]: Perl version 5.008005



What does it mean??


All times are GMT +2. The time now is 22:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.