HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   The Perfect Setup - Debian Sarge (3.1) "quote problem" (http://www.howtoforge.com/forums/showthread.php?t=3982)

crow 29th April 2006 10:18

The Perfect Setup - Debian Sarge (3.1) "quota problem"
 
I folowed great howto for The Perfect Setup - Debian Sarge (3.1), but i use Debian 3.1 r2 netinstall cd. Installation went find, but when i did come on Page3 to "quote" installation i get some problem and cant get it working. Hier is what i have done:
Quote:

crow:/home/crow# pico /etc/fstab
crow:/home/crow# touch /quota.user /quota.group
crow:/home/crow# chmod 600 /quota.*
crow:/home/crow# mount -o remount /
crow:/home/crow# quotacheck -avugm
quotacheck: WARNING - Quotafile //quota.user was probably truncated. Can't save quota settings...
quotacheck: WARNING - Quotafile //quota.group was probably truncated. Can't save quota settings...
quotacheck: Scanning /dev/hda2 [/] done
quotacheck: Checked 1824 directories and 26928 files
crow:/home/crow# quotaon -avug
quotaon: Cannot find quota file on / [/dev/hda2] to turn quotas on/off.
quotaon: Cannot find quota file on / [/dev/hda2] to turn quotas on/off.
crow:/home/crow#
/etc/fstab look like this:
Quote:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda2 / ext3 defaults,errors=remount-ro,usrquota,grpquota 0 1
/dev/hda5 none swap sw 0 0
/dev/hdb /media/cdrom0 iso9660 ro,user,noauto 0 0

I must sey that i switch to Kernel 2.6.16.11 dont know is there quota support added, but i think i have tried on vanila Debian and it was the same error?

Thnx

falko 29th April 2006 13:39

Can you try the same with /aquota.user and /aquota.group instead of /quota.user and /quota.group?

crow 29th April 2006 14:23

Quote:

Originally Posted by falko
Can you try the same with /aquota.user and /aquota.group instead of /quota.user and /quota.group?

I have tried with /aquota.user and /aguota.grup
Hier is output:
Quote:

crow:/home/crow# touch /aquota.user /aquota.group
crow:/home/crow# chmod 600 /aquota.*
crow:/home/crow# mount -o remount /
crow:/home/crow# quotacheck -avugm
quotacheck: WARNING - Quotafile //aquota.user was probably truncated. Can't save quota settings...
quotacheck: WARNING - Quotafile //aquota.group was probably truncated. Can't save quota settings...
quotacheck: Scanning /dev/hda2 [/] done
quotacheck: Checked 3157 directories and 40047 files
crow:/home/crow# quotaon -avug
quotaon: Cannot find quota file on / [/dev/hda2] to turn quotas on/off.
quotaon: Cannot find quota file on / [/dev/hda2] to turn quotas on/off.
crow:/home/crow#
Same thing.
WHat there is two slash in "quotacheck: WARNING - Quotafile //aquota.user "...

Thnx for trying help.

falko 29th April 2006 14:33

Can you check in your kernel config file in /boot that quota is enabled?

What happens after you run
Code:

modprobe quota_v1
modprobe quota_v2

?

crow 29th April 2006 15:14

Quote:

Originally Posted by falko
Can you check in your kernel config file in /boot that quota is enabled?

What happens after you run
Code:

modprobe quota_v1
modprobe quota_v2

?

What i have found in /boot/config-2.6.16.11 about quota is:
Quote:

# CONFIG_QUOTA is not set
and output for modprobe:
Quote:

crow:/boot# pico config-2.6.16.11
crow:/boot# modprobe quota_v1
FATAL: Module quota_v1 not found.
crow:/boot# modprobe quota_v2
FATAL: Module quota_v2 not found.
crow:/boot#
So i think i need to compile kernel with quota support... :)

crow 29th April 2006 17:42

Replaying to myself:

After adding quota support in Kernle 2.6.16.11 quota is working normaly.
Let me check does it work with ISPConfig.


All times are GMT +2. The time now is 13:00.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.