HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=21)
-   -   MyDNSConfig does not replicate master -> slave (http://www.howtoforge.com/forums/showthread.php?t=39742)

torusturtle 29th September 2009 16:46

MyDNSConfig does not replicate master -> slave
 
I installed MyDNSConfig on 2 servers.

On the second installation I entered these values:
Quote:

Select language (en,de) [en]:

Installation mode (standard,expert) [standard]: expert

Full qualified hostname (FQDN) of the server, eg server1.domain.tld [ns2.domain.tld]:

MySQL server hostname [localhost]:

MySQL root username [root]:

MySQL root password []: PASSWORD

MySQL database to create [dbmydnsconfig]:

MySQL charset [utf8]:

Shall this server join an existing MyDNSConfig multiserver setup (y,n) [n]: y

MySQL master server hostname []: ns1.domain.tld

MySQL master server root username [root]:

MySQL master server root password []: PASSWORD

MySQL master server database name [dbmydnsconfig]:

Adding MyDNSConfig server record to database.

Configure DNS Server (y,n) [y]:

Configuring MyDNS

Hint: If this server shall run the MyDNSConfig interface, select 'y' in the next option.

Configure Apache Server (y,n) [y]:

Configuring Apache
Configure Firewall Server (y,n) [y]:

Configuring Firewall
Install MyDNSConfig Web-Interface (y,n) [y]:

Installing MyDNSConfig
MyDNSConfig Port [8080]:

Installing Crontab
Restarting web server: apache2 ... waiting .
Installation completed.
I have now a working MyDNSConfig installation on the second (slave) server but the data from the master is not replicated.

/var/log/ispconfig/ispconfig.log:
Quote:

29.09.2009-17:10 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
29.09.2009-17:10 - DEBUG - No Updated records found, starting only the core.
29.09.2009-17:10 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
29.09.2009-17:11 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
29.09.2009-17:11 - DEBUG - No Updated records found, starting only the core.
29.09.2009-17:11 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
I also changed modules.inc.php like desribed in slave dns picking up on the master dns

What else do I have to configure/execute to trigger a replication?

HooGLaNDeR 30th September 2009 19:03

I have exactly the same issue. So far no fix found.

torusturtle 23rd November 2009 14:19

I have created a bug report:
FS#991 - Master -> Slave replication not working

You can vote for this issue to give it more weight.

till 23rd November 2009 14:46

There is no such feature as master slave replication in mydnsconfig. Mydnsconfig currently supports only the management of multiple dns servers but no direct replication. So I changed your report to feature request.

rockstar9840 5th November 2010 14:35

@torusturtle, nice bug report.


All times are GMT +2. The time now is 19:00.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.