HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Problem with the installation of Dokeos (LMS) in ISPConfig (http://www.howtoforge.com/forums/showthread.php?t=3922)

jofranco 25th April 2006 23:50

Problem with the installation of Dokeos (LMS) in ISPConfig
 
Hi:

I am installing Dokeos ( Learning Management System) in ISPConfig 2.2.0

After finishing the Installation it appears the following error when I enter homepage:

[Sat Apr 22 19:18:20 2006] [error] [client xX.XX.XX.XX] PHP Fatal error: main() [function.require]: Failed opening required 'database.lib.php' (include_path='.:/php/includes') in /var/www/web8/web/cursos2006/claroline/inc/lib/groupmanager.lib.php on line 36

// Directories in Dokeos
$rootWeb="http://XX.XX.XX.XX/cursos2006/";
$urlServer=$rootWeb;
$serverAddress=$rootWeb;
$rootSys="/var/www/web8/web/cursos2006/";
$webDir=$rootSys;
$urlAppend="/cursos2006";

//Directories in ISPConfig

[root@host web]# pwd
/var/www/web8/web
[root@host web]# ls -l
total 16
drwxr-xr-x 7 apache web8 4096 abr 22 17:44 cursos2006
drwxrwxr-x 2 apache web8 4096 abr 21 19:22 error
-rw-rw-r-- 1 apache web8 1213 abr 21 19:22 index.html
drwxr-xr-x 2 apache web8 4096 abr 22 04:00 stats


[root@host web]# cd cursos2006/claroline/inc/lib/
[root@host lib]# ls -l
total 664
-rw-r--r-- 1 apache web8 60276 oct 3 2005 add_course.lib.inc.php
-rw-r--r-- 1 apache web8 6722 ago 24 2004 auth.lib.inc.php
-rw-r--r-- 1 apache web8 8716 feb 1 05:51 classmanager.lib.php
-rw-r--r-- 1 apache web8 43663 mar 1 07:18 course.lib.php
-rw-r--r-- 1 apache web8 32793 jun 10 2005 database.lib.php
-rw-r--r-- 1 apache web8 13842 may 30 2005 debug.lib.inc.php
-rw-r--r-- 1 apache web8 18506 ago 19 2005 display.lib.php
-rw-r--r-- 1 apache web8 24265 oct 18 2005 document.lib.php
-rw-r--r-- 1 apache web8 15549 jun 23 2005 events.lib.inc.php
-rw-r--r-- 1 apache web8 27863 abr 22 2005 export.lib.inc.php
-rw-r--r-- 1 apache web8 8477 ago 9 2005 fileDisplay.lib.php
-rw-r--r-- 1 apache web8 22234 jul 10 2005 fileManage.lib.php
-rw-r--r-- 1 apache web8 59553 sep 9 2005 fileUpload.lib.php
-rw-r--r-- 1 apache web8 45983 ene 24 04:41 groupmanager.lib.php
-rw-r--r-- 1 apache web8 49 feb 5 2004 index.html
-rw-r--r-- 1 apache web8 2902 jun 14 2005 mail.lib.inc.php
-rw-r--r-- 1 apache web8 53262 sep 30 2005 main_api.lib.php
-rw-r--r-- 1 apache web8 5994 may 1 2005 online.inc.php
drw-r--r-- 2 apache web8 4096 abr 6 09:06 pclzip
-rw-r--r-- 1 apache web8 4174 feb 24 2005 session_handler.class.php
-rw-r--r-- 1 apache web8 23670 ago 24 2004 stats.lib.inc.php
-rw-r--r-- 1 apache web8 19202 may 10 2005 statsUtils.lib.inc.php
-rw-r--r-- 1 apache web8 11533 jun 1 2005 system_announcements.lib.php
-rw-r--r-- 1 apache web8 6578 ago 9 2005 tablesort.lib.php
-rw-r--r-- 1 apache web8 6753 may 4 2005 text.lib.php
-rw-r--r-- 1 apache web8 12859 may 10 2005 tool_access_details.lib.php
-rw-r--r-- 1 apache web8 8917 oct 28 09:31 usermanager.lib.php
-rw-r--r-- 1 apache web8 21857 mar 16 2005 xht.lib.php
-rw-r--r-- 1 apache web8 32976 mar 16 2005 xmd.lib.php


Thank.

till 26th April 2006 10:54

Have you enabled PHP Safemode? Maybe Dokeos does not support Safemode. Try to disable it for the website.

Also check your php ini file(s), if the include path contains ".", which means that relative includes are allowed.

jofranco 27th April 2006 00:28

Safe Mode is Off in /etc/php.ini

;
; Safe Mode
;
safe_mode = Off


and include_path="." in /etc/php.ini

; UNIX: "/path1:/path2"
;include_path = ".:/php/includes"
include_path = ".:/php/includes"

It appears the same error :

[Wed Apr 26 16:16:34:22] [error] [client XX.XX.XX.XX] PHP Fatal error: main() [<a href='function.require'>function.require</a>]: Failed opening required 'database.lib.php' (include_path='.:/php/includes') in /var/www/web8/web/cursos2006/claroline/inc/lib/groupmanager.lib.php on line 36


Thank

till 27th April 2006 10:56

Quote:

Originally Posted by jofranco
Safe Mode is Off in /etc/php.ini

;
; Safe Mode
;
safe_mode = Off

ISPConfig overrides the safemode setting in your php.ini. Make sure that the php safemode checkbox in ISPConfig is not checked for this website.

jofranco 28th April 2006 01:45

Thatīs just fine, THANKS


All times are GMT +2. The time now is 23:33.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.