HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   error in installer_base.lib.php shows up while configuring in expert-mode (http://www.howtoforge.com/forums/showthread.php?t=39198)

d@ten 14th September 2009 23:12

error in installer_base.lib.php shows up while configuring in expert-mode
 
Got this error while configuring my master-server:

Code:

>> Initial configuration 

Operating System: Debian Lenny/Sid or compatible

    Following will be a few questions for primary configuration so be careful.
    Default values are in [brackets] and can be accepted with <ENTER>.
    Tap in "quit" (without the quotes) to stop the installer.


Select language (en,de) [en]:

Installation mode (standard,expert) [standard]: expert

Full qualified hostname (FQDN) of the server, eg server1.domain.tld  [test]: master

MySQL server hostname [localhost]:

MySQL root username [root]:

MySQL root password []: foobar

MySQL database to create [dbispconfig]:

MySQL charset [utf8]:

Shall this server join an existing ISPConfig multiserver setup (y,n) [n]:

Adding ISPConfig server record to database.

Configure Mail (y,n) [y]: n

Configure Jailkit (y,n) [y]: n

Configure FTP Server (y,n) [y]: n

Configure DNS Server (y,n) [y]: n


Hint: If this server shall run the ispconfig interface, select 'y' in the 'Configure Apache Server' option.

Configure Apache Server (y,n) [y]: 

Configuring Apache

Warning: Invalid argument supplied for foreach() in /root/trunk/install/lib/installer_base.lib.php on line 811
Configuring vlogger
Configure Firewall Server (y,n) [y]:

Adding the following to installer_base.lib.php:

Code:

                if(count($records) > 0) {
+                        swriteln("======================\n");
+                        swriteln(print_r($records) . "\n");
+                        swriteln($records . "\n");
+                        swriteln(var_dump($records) . "\n");
+                        swriteln("======================\n");
                        foreach($records as $rec) {

shows me the following:

Code:

[..]
Hint: If this server shall run the ispconfig interface, select 'y' in the 'Configure Apache Server' option.

Configure Apache Server (y,n) [y]:

Configuring Apache
======================

1



bool(false)


======================


Warning: Invalid argument supplied for foreach() in /root/trunk/install/lib/installer_base.lib.php on line 816
Configuring vlogger
Configure Firewall Server (y,n) [y]: ^C

$records is false (therefore not an integer) and in PHP count(false) results in <true>.

I suggest changing
Code:

if(count($records) > 0) {
in sth. like
Code:

if((count($records) > 0) && ($records)) {
Weird.

Greetings

d@ten

till 15th September 2009 13:51

Thanks. It has been fixed in svn.


All times are GMT +2. The time now is 02:04.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.