HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   incoming mail has stopped (http://www.howtoforge.com/forums/showthread.php?t=3913)

darthpaul 25th April 2006 15:13

incoming mail has stopped
 
we've been running ispconfig for a few months now and aside from a few minor issues it has run fine. A couple things keep coming up though and today I cannot receive any emails.

1.) The recycle bin will never empty.
2.) My changes to aliases or autoresponse sometimes do not take effect

Right now the web interface for ispconfig shows me all the correct email accounts and aliases, but the /etc/postfix/virtusertable is blank so there are no incoming email accounts that ispconfig is seeing. Are all these issues related? What can I do to force ispconfig to write out a good virtusertable from the web interface?

Dave

falko 25th April 2006 15:37

What's the output of
Code:

ls -la /root/isponfig
? Are there any errors in /home/admispconfig/ispconfig/ispconfig.log?

darthpaul 25th April 2006 16:04

as requested...
 
There were no errors in the log file. HEre is the list of the ispconfig directory:

.ispconfig_lock
.old_path_httpd_root
cronolog
cronosplit
httpd
isp
list1.txt
openssl
php
scripts
standard_cgis
sv
uninstall

darthpaul 25th April 2006 16:07

one more
 
I found a command in the forums for rebuilding the virtusertable called postmap. This has fixed the incoming mail issue, but once I logged into the web interface, the recycle bin is still not empty.

It seems the issues I have run into most are the virtusertable becoming corrupt and the recycle bin not emptying. Last week I audited the user accounts and aliases using the web interface and deleted two accounts. None of my changes took effect until I forced the update using postmap and the recycle bin still will not empty the deleted accounts.

Am I missing something?

falko 26th April 2006 15:00

ISPConfig is locked (maybe because of some abnormal termination).
Please do this:
Code:

rm -f /root/ispconfig/.ispconfig_lock

darthpaul 27th April 2006 17:08

lock file
 
I deleted the lock file and emptied the recycle bin from the web interface. Another lock file was created and the recycle bin still has the account I wish to remove.

Is there an additional resource that explains when lock files are created and why?

As far as the trouble I am having with the virtusertable, what does the web interface use to display the current accounts and aliases? It seems the web interface is always giving me correct information even when the virtuser table does not. What other tools are there for forcing ispconfig to use the account and alias information displayed in the web interface?

till 27th April 2006 20:53

Please delete the lock file and then run the command:

/root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

Did you get a segfault?

darthpaul 28th April 2006 14:52

ran the command
 
And got this result:

ls: /etc/apache2/vhosts.d/*.conf: No such file or directory
start
Segmentation fault

till 28th April 2006 15:01

Please try if this fix helps you:

http://www.howtoforge.com/forums/showthread.php?t=3695

darthpaul 28th April 2006 15:35

That did it!
 
Much obliged for all your help. Now the recycle bin can empty and the virtusertable shows the deleted accounts have been removed.

Thanks again.


All times are GMT +2. The time now is 21:43.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.