HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (
-   General (
-   -   FTP User + Mail Adress (

Randall Flagg 31st August 2009 21:52

FTP User + Mail Adress
Well... I'm not the rigtfull admin of my server, but I'm the one that has to find a way out of this mess, so I'll explain you guys the thing.

We have an external mail server for most of our clients, and most of them use mails form that server. Now, with the update of servers we decided to install ISPconfig 2.2 into our Centos.
Everything cool with ISP config, but then the problem started.

Many (not to say all of them) of our clients have in their server the "contact us" part, where people send emails from the server to and account of the client, like lets say:

Now, the problem comes here: that client have their email address in our mail server, so the only thing the ISPconfig has to do is Send E-mails to that adress.
But that doesn't happend.
Why? Becouse ISPConfig believe he is the mail server, trying to send mail to him self, ergo, the mail never reachs its destination.

To be more clear, I'll tell you step by step what I normally do.
I create my new domain:, I give that domain php and FTP access. I DON'T check the DNS or DNS MX since we administrate that in out master DNS server.

Then I create an user via the email, so I can have FTP access. (I never found a way to create only FTP user, without mail.)

And then is done.
But since I alredy create a mail with (for the FT user), ISPConfig believes he is the mail server.

I've already check the part of "External Mailserver", but nothing. No result, and my "Contact us" mail get stuck in the ISPConfig.

Any idea for this problem, please? I'm kinda lost.

till 1st September 2009 13:00

You missed the co-domain settings! The website is, so if you set it to external mailserver, it affect als emails for, the co-domain is (without www), so you have to set this to external mailserver if you want to have an affect on email addresses like So just set the website AND co-domain to external mailserver in ispconfig.

See also the FAQ:

Randall Flagg 1st September 2009 16:38

Thanks! It worked out well! =)

All times are GMT +2. The time now is 20:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.