HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Developers' Forum (http://www.howtoforge.com/forums/forumdisplay.php?f=18)
-   -   Problem with .htacess and web server (http://www.howtoforge.com/forums/showthread.php?t=38534)

kings 26th August 2009 22:26

Problem with .htacess and web server
 
I'm administrator of web and e-mail server built on a Mandriva 2009.0( 64-bit) and ISPConfig 2.2.32
On this server is hosted sites built only based on Joomla 1.5. I can’t find where is the problem with the file named (.htaccess ). WEB server with this file stops working and ignore it. At the moment it was renamed .htaccess on htaccess.txt everything goes normally. But in this case the SEO Joomla optimization is lost. Please, help me to solve this problem.

falko 27th August 2009 13:58

Any errors in the web site's error log or the overall Apache error log?

madmucho 27th August 2009 14:04

directive
 
For joomla sites i use this Apache Directive and they works ok.

Code:

<Directory /var/www/webxx/web/> 
Options +Includes +FollowSymlinks -Indexes 
AllowOverride All 
Order allow,deny 
Allow from all 
<Files ~ "^\.ht"> 
Deny from all 
</Files> 
</Directory>

Your enviroment works ok and now you have this problem? Or this problem is after ISPConfig installation?

kings 27th August 2009 17:41

Problem with .htaccess
 
Quote:

Originally Posted by madmucho (Post 202253)
For joomla sites i use this Apache Directive and they works ok.

Code:

<Directory /var/www/webxx/web/> 
Options +Includes +FollowSymlinks -Indexes 
AllowOverride All 
Order allow,deny 
Allow from all 
<Files ~ "^\.ht"> 
Deny from all 
</Files> 
</Directory>

Your enviroment works ok and now you have this problem? Or this problem is after ISPConfig installation?

Thank you! BUT I have new question:
Is necessary to make similar changes in remaining sections in httpd.conf such as <Directory /var/www/*/user/*/web> and <Directory /var/www/*/cgi-bin>?

madmucho 27th August 2009 21:45

for all
 
as you want you can change global settings for vhosts to accept .htaccess directives or do it per site in ispconfig system, best practice is dont allow users .htaccess if they dont need it or dont know what that is :-) that is for security reason.

Global directive can be placed in..
Code:

/etc/httpd/conf/httpd.conf
at the end of file

Code:

<Directory /var/www/*/web>
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride All
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

For Joomla that will be enough. But that is not recomended setting...

kings 28th August 2009 01:01

Re broblem with .htaccess
 
Quote:

Originally Posted by madmucho (Post 202313)
as you want you can change global settings for vhosts to accept .htaccess directives or do it per site in ispconfig system, best practice is dont allow users .htaccess if they dont need it or dont know what that is :-) that is for security reason.

Global directive can be placed in..
Code:

/etc/httpd/conf/httpd.conf
at the end of file

Code:

<Directory /var/www/*/web>
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride All
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

For Joomla that will be enough. But that is not recomended setting...

Special thanks!
When i make this chages in /etc/httpd/conf/httpd.conf result is FULL ZERO.Apache stoped imediately in log file - not eny trace for reason of stop. Falko sayd Quote"Any errors in the web site's error log or the overall Apache error log" end quote
When I put this <Directory /var/www/*/web>
Options +Includes +FollowSymlinks -Indexes
AllowOverride All
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

in /etc/httpd/vhost/Vhosts_ispconfig.conf
Code:
###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 192.168.1.2:80
<VirtualHost 192.168.1.2:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]
</IfModule>
</VirtualHost>

:)<Directory /var/www/*/web>
Options +Includes +FollowSymlinks -Indexes
AllowOverride All
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>:)
#
#
######################################
# Vhost: www.example.com:80
######################################
#
#
<VirtualHost 192.168.1.2:80>
and etc code...

IT IS WORK FULL. APACHE DON"T STOP. YOU CAN TO CHANGE htaccess.txt
to .htaccess!

THANK YOU MADMUCHO

madmucho 28th August 2009 08:57

This location isnt good, this directive will be overwriten nextime when you make changes in ispconfig web managment. This vhost directives is generated.

Try put that directive at end of httpd.conf and then in console httpd -t for syntax check.

kings 1st September 2009 19:03

Quote:

Originally Posted by madmucho (Post 202338)
This location isnt good, this directive will be overwriten nextime when you make changes in ispconfig web managment. This vhost directives is generated.

Try put that directive at end of httpd.conf and then in console httpd -t for syntax check.

Ok
Thank you I put on httpd.conf


All times are GMT +2. The time now is 14:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.