HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   MySQL is not running!! (http://www.howtoforge.com/forums/showthread.php?t=383)

iceberg 25th August 2005 18:10

MySQL is not running!!
 
hi all, during installation i got this error

Code:

ERROR: MySQL is not running! Please start your MySQL database and run the ISPConfig setup again.
i am running MySQL server...

Code:

# service mysqld status
mysqld (pid 31869) is running...

and here...

Code:

# mysqladmin ping
mysqld is alive

So, any suggestions??
Thanks for reading

falko 25th August 2005 19:06

Do you see MySQL when you run
Code:

netstat -tap
? MySQL has to run over TCP, not on local Unix sockets. To change that, edit /etc/my.cnf, comment out skip-networking and restart MySQL.

iceberg 25th August 2005 19:16

i can't skip-networking in /etc/my.cnf. here is /etc/my.cnf

Code:

more /etc/my.cnf

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

# Default to using old password format for compatibility with old and
# shorter password hash.
# Reference: http://dev.mysql.com/doc/mysql/en/Password_hashing.html
old_passwords=1

[mysql.server]
user=mysql
basedir=/var/lib

[mysqld_safe]
err-log=/var/log/mysqld/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid


falko 25th August 2005 19:27

Can you post the output of
Code:

netstat -tap
here?

Quote:

i can't skip-networking in /etc/my.cnf. here is /etc/my.cnf
Depending on your distribution there might be further configuration files under /etc/sysconfig or /etc/default.

iceberg 25th August 2005 19:36

Thanks, i figured it out

Avatar 22nd November 2005 16:07

Since I upgraded ISPConfig from 2.1.0 to 2.1.1 today, I get an error by eMail that mysql is not running, every half an hour. But mysql IS running:

Code:

# netstat -tap
tcp        0      0 server.domain:mysql  *:*                    LISTEN    2446/mysqld

I also don't have an "skip-networking" option in my my.cnf, but the new way of binding to localhost isn't active, too:

Code:

# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address            = 123.456.789.10

The my.cnf seems to be touched during the installation, but I cannot see any changes. I already rebootet the server. No results, I still get the mail.

It's a debian 3.1 distribution.

What can I do? :(
--
Best regards...
Ace

falko 22nd November 2005 16:32

Quote:

Originally Posted by Avatar
Code:

# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address            = 123.456.789.10


MySQL is bound to listen only on 123.456.789.10 whereas ISPConfig tries to connect to MySQL on 127.0.0.1 to see if it's still running. Either change the IP address to 127.0.0.1 in /etc/mysql/my.cnf, or comment out the bind-address line. In both cases, restart MySQL afterwards.

Quote:

Originally Posted by Avatar
The my.cnf seems to be touched during the installation, but I cannot see any changes. I already rebootet the server. No results, I still get the mail.

No, ISPConfig doesn't touch /etc/mysql/my.cnf. You can have a look at the ISPConfig sources.

Avatar 22nd November 2005 17:02

Hi!

Quote:

Originally Posted by falko
MySQL is bound to listen only on 123.456.789.10 whereas ISPConfig tries to connect to MySQL on 127.0.0.1 to see if it's still running. Either change the IP address to 127.0.0.1 in /etc/mysql/my.cnf, or comment out the bind-address line. In both cases, restart MySQL afterwards.

Thanx! Worked. :)

Quote:

No, ISPConfig doesn't touch /etc/mysql/my.cnf. You can have a look at the ISPConfig sources.
I believe you. ;) But maybe then he just didn't complain before. :D
--
Best regards...
Ace

bassplayer 2nd January 2008 05:00

mysql not runing during install
 
I use fresh install Redhat 9.0
during install it says MySQL not running,
my> netstat -tap
tcp 0 0 *:mysql *:* LISTEN 2997/

my /etc/mycnf
[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

[mysql.server]
user=mysql
basedir=/var/lib

[safe_mysqld]
err-log=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

BTW, i dont see php-mysql on my instalation, i cannot find in redhat9 disc,
is it the problem.
thanks in advance.

falko 2nd January 2008 23:31

Is there a special reason why you're using such an old distribution? I suggest you try Fedora 8 or CentOS 5.1 instead.


All times are GMT +2. The time now is 10:00.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.