HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   E: Sub-process /usr/bin/dpkg returned an error code (1) (http://www.howtoforge.com/forums/showthread.php?t=38241)

ergti 16th August 2009 06:00

E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Hi, after command, errors.

Code:

m1:~# apt-get install apache2 apache2.2-common apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common php5-gd php5-mysql php5-imap phpmyadmin php5-cli php5-cgi libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-mcrypt mcrypt php5-imagick imagemagick libapache2-mod-suphp
Reading package lists... Done
Building dependency tree
Reading state information... Done
apache2 is already the newest version.
apache2.2-common is already the newest version.
apache2-doc is already the newest version.
apache2-mpm-prefork is already the newest version.
apache2-utils is already the newest version.
libexpat1 is already the newest version.
ssl-cert is already the newest version.
libapache2-mod-php5 is already the newest version.
php5 is already the newest version.
php5-common is already the newest version.
php5-gd is already the newest version.
php5-mysql is already the newest version.
php5-imap is already the newest version.
phpmyadmin is already the newest version.
php5-cli is already the newest version.
php5-cgi is already the newest version.
libapache2-mod-fcgid is already the newest version.
apache2-suexec is already the newest version.
php-pear is already the newest version.
php-auth is already the newest version.
php5-mcrypt is already the newest version.
mcrypt is already the newest version.
php5-imagick is already the newest version.
imagemagick is already the newest version.
libapache2-mod-suphp is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
14 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up libapache2-mod-php5 (5.2.6.dfsg.1-1+lenny3) ...
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/FrontEnd/ScreenSize.pm line 33.
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/FrontEnd/ScreenSize.pm line 48.
open2: fork failed: Cannot allocate memory at /usr/share/perl5/Debconf/ConfModule.pm line 59
dpkg: error processing libapache2-mod-php5 (--configure):
 subprocess post-installation script returned error exit status 12
Setting up php5-cgi (5.2.6.dfsg.1-1+lenny3) ...
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/FrontEnd/ScreenSize.pm line 33.
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/FrontEnd/ScreenSize.pm line 48.
open2: fork failed: Cannot allocate memory at /usr/share/perl5/Debconf/ConfModule.pm line 59
dpkg: error processing php5-cgi (--configure):
 subprocess post-installation script returned error exit status 12
dpkg: dependency problems prevent configuration of suphp-common:
 suphp-common depends on php4-cgi | php5-cgi; however:
  Package php4-cgi is not installed.
  Package php5-cgi is not configured yet.
dpkg: error processing suphp-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libapache2-mod-suphp:
 libapache2-mod-suphp depends on suphp-common (= 0.6.2-3); however:
  Package suphp-common is not configured yet.
dpkg: error processing libapache2-mod-suphp (--configure):
 dependency problems - leaving unconfigured
Setting up php5-cli (5.2.6.dfsg.1-1+lenny3) ...
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/FrontEnd/ScreenSize.pm line 33.
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/FrontEnd/ScreenSize.pm line 48.
open2: fork failed: Cannot allocate memory at /usr/share/perl5/Debconf/ConfModule.pm line 59
dpkg: error processing php5-cli (--configure):
 subprocess post-installation script returned error exit status 12
dpkg: dependency problems prevent configuration of php-pear:
 php-pear depends on php5-cli | php4-cli; however:
  Package php5-cli is not configured yet.
  Package php4-cli is not installed.
dpkg: error processing php-pear (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php-auth:
 php-auth depends on php-pear (>= 5.2.0-8); however:
  Package php-pear is not configured yet.
dpkg: error processing php-auth (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5:
 php5 depends on libapache2-mod-php5 (>= 5.2.6.dfsg.1-1+lenny3) | libapache2-mod-php5filter (>= 5.2.6.dfsg.1-1+lenny3) | php5-cgi (>= 5.2.6.dfsg.1-1+lenny3); however:
  Package libapache2-mod-php5 is not configured yet.
  Package libapache2-mod-php5filter is not installed.
  Package php5-cgi is not configured yet.
dpkg: error processing php5 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-gd:
 php5-gd depends on phpapi-20060613+lfs; however:
  Package phpapi-20060613+lfs is not installed.
  Package libapache2-mod-php5 which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cli which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cgi which provides phpapi-20060613+lfs is not configured yet.
dpkg: error processing php5-gd (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-imagick:
 php5-imagick depends on phpapi-20060613+lfs; however:
  Package phpapi-20060613+lfs is not installed.
  Package libapache2-mod-php5 which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cli which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cgi which provides phpapi-20060613+lfs is not configured yet.
dpkg: error processing php5-imagick (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-imap:
 php5-imap depends on phpapi-20060613+lfs; however:
  Package phpapi-20060613+lfs is not installed.
  Package libapache2-mod-php5 which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cli which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cgi which provides phpapi-20060613+lfs is not configured yet.
dpkg: error processing php5-imap (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-mcrypt:
 php5-mcrypt depends on phpapi-20060613+lfs; however:
  Package phpapi-20060613+lfs is not installed.
  Package libapache2-mod-php5 which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cli which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cgi which provides phpapi-20060613+lfs is not configured yet.
dpkg: error processing php5-mcrypt (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-mysql:
 php5-mysql depends on phpapi-20060613+lfs; however:
  Package phpapi-20060613+lfs is not installed.
  Package libapache2-mod-php5 which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cli which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cgi which provides phpapi-20060613+lfs is not configured yet.
dpkg: error processing php5-mysql (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of phpmyadmin:
 phpmyadmin depends on libapache2-mod-php5 | libapache-mod-php5 | php5-cgi | php5 | libapache2-mod-php4 | libapache-mod-php4 | php4 | php4-cgi; however:
  Package libapache2-mod-php5 is not configured yet.
  Package libapache-mod-php5 is not installed.
  Package php5-cgi is not configured yet.
  Package php5 is not configured yet.
  Package libapache2-mod-php4 is not installed.
  Package libapache-mod-php4 is not installed.
  Package php4 is not installed.
  Package php4-cgi is not installed.
 phpmyadmin depends on php5-mysql | php5-mysqli | php4-mysql; however:
  Package php5-mysql is not configured yet.
  Package php5-mysqli is not installed.
  Package php4-mysql is not installed.
 phpmyadmin depends on php5-mcrypt | php4-mcrypt; however:
  Package php5-mcrypt is not configured yet.
  Package php4-mcrypt is not installed.
dpkg: error processing phpmyadmin (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libapache2-mod-php5
 php5-cgi
 suphp-common
 libapache2-mod-suphp
 php5-cli
 php-pear
 php-auth
 php5
 php5-gd
 php5-imagick
 php5-imap
 php5-mcrypt
 php5-mysql
 phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)

Debian 5 in openvz.

Thanks for help.

till 16th August 2009 13:36

Your OpenVZ VM has not enough memory to install the software. You have to assign more memory to the vm. You can check this with:

cat /proc/user_beancounters


All times are GMT +2. The time now is 18:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.