HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Technical (http://www.howtoforge.com/forums/forumdisplay.php?f=8)
-   -   Screen Display not working after installing codecs (http://www.howtoforge.com/forums/showthread.php?t=38149)

bakhshu 12th August 2009 01:04

Screen Display not working after installing codecs
 
Is there a way to boot the machine into single user/plain text (no X11) mode? So I can login and uninstall the codecs?

I went through the regular installation of OpenSuse 11.1 (Gnome desktop) on a Dell Inspiron 1501. Everything was smooth thankfully, got the wireless up and running, etc.

Then I found this wonderful article on how to further enrich your desktop:
http://www.howtoforge.com/the-perfec...-11.1-gnome-p4

In section 7.1 of this link, there are URLs from where you can download and install additional codecs, etc, and then some root commands to complete the process. BTW, I started at the beginning of this article by doing each step in the order given.

When I followed through with the codec installation, logged back out and in, my screen went blank. The machine was up and running and I could ping it, but no display at all.

Tried rebooting, nothing, then rebooted in failsafe mode, still nothing. During boot, the splash screen is there, but as soon as the progress bar completes to go to the login screen, it blanks out.

So I am looking for tips on what to do short of reimaging the machine from scratch because I have made so many other customizations already.

I tried booting from the OS dvd and attempting various repair options, but it never mentioned anything about repairing the screen display or any drivers for it.

matey 18th August 2009 12:33

Usually you can pres control alt and F1 thru F6 and get into the terminal screen.
then you can log in and do a ps ax to see the processes, kill the proc. number (very first numbers on the left).
you may have to do
ps ax |more
to see all processes.

btw kill the proc related to your GUI.
Also once you get into the terminal screen you can re config with this command;

sudo dpkg-reconfigure xserver-xorg
or

sudo dpkg-reconfigure -phigh xserver-xorg
(or man xorg.conf ) to read the manual

To take the GUI from starting permanently do;

update-rc.d -f gdm remove (or kdm or xdm whichever youre using)

to put it back into startup;

update-rc.d -f gdm default (or kdm or xdm instead of gdm)

good luck!

BTW2 hopefully someone with Linux experience will solve this problem. I am not an expert.

bakhshu 28th August 2009 04:21

Screen Display not working after installing codecs
 
Thanks so much for this post, it is really helpful. And it worked beautifully.

matey 28th August 2009 12:25

Thanks for the response!
I am sorry that I forgot to mention (just for the record) if you press control + alt and back-space keys you can exit your GUI as well.
The reason I posted this was that I had a similar problem recently and I tried to get into terminal by Alt F1 / F2 etc, but I could not?! Then I used ctrl-alt-back_space and only then it worked!?
Glad the info was useful to you !


All times are GMT +2. The time now is 20:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.