HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Developers' Forum (http://www.howtoforge.com/forums/forumdisplay.php?f=33)
-   -   httpd and phpmyadmin recirect issue (http://www.howtoforge.com/forums/showthread.php?t=38111)

moglia 10th August 2009 15:38

httpd and phpmyadmin recirect issue
 
I generated certificate at cacert.org and used it on 8080 port changes ispconfig.vhost to use certificate. (segure open ssl).

Im using debian and phpmyadmin package donīt have autoconfigurations to put phpmyadmin alias to https. Only for http.

Itīs make sense for use the same certificate if ispconfig operates with ssl put phpmyadmin alias on same virtual host used by ispconfig.

phpmyadmin and ispconfig can share the same host and certificate and all operate on secure connections. because both sending password over networks.

Im copy and paste /etc/apache2/conf.d/phpmyadmin.conf on
/etc/apache2/sites-available/ispconfig.vhost now works perfectlly.

i modified the file on /interface/web/sites/database_phpmyadmin.php to reflect this modifications and tested on debian not on another distros and uploaded to svn.

database_phpmyadmin.php
-----------------------------------
isset($_SERVER['HTTPS'])? $http = 'https' : $http = 'http';
($_SERVER["SERVER_PORT"] != '80' and $http == 'https')? $serverPort = ':'.$_SERVER["SERVER_PORT"] : $serverPort = '';
header('location:'.$http.'://'.$serverData['server_name'].$serverPort.'/phpmyadmin');
-------------------------------------
If using segure conections phpmyadmin alias not configured on 443 port (apache2) by default to recive url rediretion. The idea is put alias on same ispconfig host if you using ispconfig with ssl.

Another sugestion is if ispconfig is on https redirect to phpmyadmin on http.
I belive keep all on secure connection itīs better way.

Please give-me a feedback of this modifications, i considered itīs make more sense about phpmyadmin and work with ispconfig.

Itīs a simple modification at the end of file but i can not check impact of this modification on another distros.

Sugestions and comments will be apreciated. :)

till 10th August 2009 17:06

This configuration will not work when ispconfig is running as php-fcgi. You can try this by disabling mod_php in apache. Also we have not used this configuration to separate ISPConfig from phpmyadmin so the system can not be compromised by a phpmyadmin bug.

moglia 10th August 2009 17:13

Sugestion.
 
Dedicated vhost with mod_php for phpmyadmin on another port with same address and certificate is one way.


Take more liberty to admin choose a url location of phpmyadmin and configure vhost manually to do it.

Options on config at panel to specify a url of phpmyadmin. itīs a great idea no?

or

Options on config.inc.php file to set a url of phpmyadmin itīs more elegant way to solve this issue.

Whats you think about this?

till 10th August 2009 17:19

Quote:

Options on config at panel to specify a url of phpmyadmin. itīs a great idea no?
Thats already planned for 3.0.2. Same for webmail URL.

moglia 10th August 2009 17:23

I can help to do it?
 
Im using a ispconfig 3 on production enviroment.
and i can build a test enviroment and make more code contribibs insted only translation to portuguese.

I have some advanced php skills.

And i can help with bugs fixing all bugs if i can do it.

any adtional question i will use forum to talk with all developers.

actually im a simple user on bugtrack can not take tasks to me. i can not assign then for myself.

till 11th August 2009 13:52

Thank you for helping with ispconfig development.

I've adeed your bugtracker user to the developer group, so you can assign tasks to yourself.


All times are GMT +2. The time now is 06:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.