HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Trouble Creating Email Account (http://www.howtoforge.com/forums/showthread.php?t=38048)

samuch 7th August 2009 18:42

Trouble Creating Email Account
 
So I created a website for say, testtestlongdomainname.com. I then created the email domain but accidentally typed it as testestlongdomainname.com (missing one of the letters) and then created an email account for it.

After realizing this error, I deleted the email domain and re-created it. But, the account does not work. I took a look and noticed that in the /var/vmail/testtestlongdomainname.com folder there is not a subfolder for the email account created.

It looks like ispconfig is not properly creating the email account for some reason. I'm not sure if this is because the domain name is so long, or because I orginally typo'ed the domain name. How can I manually get this account created while this is looked into?

For clarification on length, the real domain name is 22 characters plus .com (I know, it's long but I didn't recommend it.

Thanks in advance. We just moved this user to our new ispconfig 3 server so they're freaking out.

till 8th August 2009 10:32

There is a known problem maildirmake command which hangs sometimes when a email account is created in ispconfig 3.0.1.3 which has been fixed in svn already and will be fixed in 3.0.1.4

samuch 8th August 2009 13:05

Thank you for the reply. However, I'm already running 3.0.1.4. I also ran ispconfig_update_from_svn.sh just in case it would help. Any thoughts on how I can manually fix this or what I can look at?

till 8th August 2009 14:35

1) Are there any changes stuck in the processing queue?
2) Enable debugging:

http://www.faqforge.com/linux/contro...n-ispconfig-3/

samuch 8th August 2009 14:53

I set the debug and restarted Apache. I then deleted the mailbox and created again. Here's what I see in the system-log:

Code:

2009-08-08 07:17          our.sever.com          Debug          Created Maildir: su -c 'maildirmake -q 104857600S /var/vmail/longdomainname.com/ed' vmail         
2009-08-08 07:17        our.server.com        Debug        Set ownership on /var/vmail/longdomainname.com/ed       
2009-08-08 07:17        our.server.com        Debug        Call function 'user_insert' in plugin 'mail_plugin' raised by event 'mail_user_insert'.       
2009-08-08 07:17        our.server.com        Debug        Processed datalog_id 258

Then when I check that directory, still nothing.

Code:

ls
our:/var/vmail/longdomainname.com # ls
our:/var/vmail/longdomainname.com #


till 8th August 2009 14:55

Please post the output of:

ls -la /var/vmail/longdomainname.com

samuch 8th August 2009 14:59

Code:

our:/var/vmail/longdomainname.com # ls -la /var/vmail/longdomainname.com/
total 8
drwx------  2 vmail vmail 4096 2009-08-07 06:31 .
drwxr-xr-x 12 vmail vmail 4096 2009-08-07 06:29 ..
our:/var/vmail/longdomainname.com #


till 8th August 2009 15:05

Thats strange. Please run the following commands as root user and then post the ls -la again:

su vmail
maildirmake /var/vmail/longdomainname.com/ed
exit

any errors in the above command?

samuch 8th August 2009 15:08

Well, I don't know what could have changed but I do have an error with maildirmake now. For reference, this is OpenSuSE 11.1.

Code:

our:/var/vmail/longdomainname.com # su vmail
vmail@our:~/longdomainname.com> maildirmake /var/vmail/longdomainname.com/ed

Program 'maildirmake' is present in package 'courier-imap', which is installed on your system.

Absolute path to 'maildirmake' is '/usr/bin/maildirmake'. Please check your $PATH variable to see whether it contains the mentioned path.

bash: maildirmake: command not found
vmail@our:~/clongdomainname.com> exit
exit


till 8th August 2009 15:12

Ok, this explains the problems. The question is now why your path variable does not contain /usr/bin anymore or why the maildirmake command disappeared.

Please post the output of:

su vmail
echo $PATH
exit

and

ls -la /usr/bin/maildirmake

and if it is not found by ls post:

which maildirmake


All times are GMT +2. The time now is 13:30.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.