HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Turning quota ON (http://www.howtoforge.com/forums/showthread.php?t=37973)

deco5003 5th August 2009 02:19

Turning quota ON
 
Is giving me this error at the system boot; quotaon: using //aquota.user on /dev/sda2 [/] Invalid Argument.
I look on the boot.msg file and found that /dev/sda2 not shows in the mounting file system section.
But when I manually try to mount tells me this device is already mounted. But in the case of /dev/sda3 the quota is turned on perfectly. Any clues

falko 5th August 2009 13:36

What are the outputs of
Code:

mount
and
Code:

fdisk -l
? What's in /etc/fstab?

deco5003 5th August 2009 18:25

Turning quota ON
 
output of mount
/dev/sda2 on / type ext3 (rw,acl,user_xattr,usrquota,grpquota)
/proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda3 on /srv type ext3 (rw,acl,user_xattr,usrquota,grpquota)
/proc on /var/lib/ntp/proc type proc (ro)
/dev/sdb1 on /mnt/USb_flash type vfat (rw)

Output Of fdisk -l
Disk /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xaecaaeca


Device Boot Start End Blocks Id System

/dev/sda1 1 96 771088+ 82 Linux swap / Solaris

/dev/sda2 * 97 2012 15390270 83 Linux

/dev/sda3 2013 4865 22916722+ 83 Linux

/dev/sdb1 1 15280 3911664 c W95 FAT32 (LBA)

FStab include this

/dev/disk/by-id/ata-WDC_WD400BB-00JHC0_WD-WMAMA8135799-part1 swap swap defaults 0 0

/dev/disk/by-id/ata-WDC_WD400BB-00JHC0_WD-WMAMA8135799-part2 / ext3 acl,user_xattr,usrquota,grpquota 1 1

/dev/disk/by-id/ata-WDC_WD400BB-00JHC0_WD-WMAMA8135799-part3 /srv ext3 acl,user_xattr,usrquota,grpquota 1 2

/dev/sdb1 /mnt/USb_flash vfat defaults,users,noauto 0 0

proc /proc proc defaults 0 0

sysfs /sys sysfs noauto 0 0

debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0

devpts /dev/pts devpts mode=0620,gid=5 0 0

falko 6th August 2009 15:44

Looks ok. Which distribution are you using?
My guess is that maybe your initrd doesn't have quota support.

deco5003 6th August 2009 15:58

Enable quota / partition
 
I am using OpenSUSe 11.1 Kernel 2.6.27.25-.0.1 pae
quota ver. 3.16
Compiled with EXT2_DIRECT HOST_ACCESS ALT_FORMAT RPC BSD-BEHAVIOR
VFS disk quota dquot-6.5.1

deco5003 11th August 2009 01:25

Turniig quota on / partition
 
Look it happens that at boot canīt turned on quota on the / partition but it did on /srv partition. And show this messages

quotaon: using //aquota.group on /dev/sda2 [/]: Invalid argument
quotaon: Maybe create new quota files with quotacheck(8)?
quotaon: using //aquota.user on /dev/sda2 [/]: Invalid argument
quotaon: Maybe create new quota files with quotacheck(8)?
/dev/sda3 [/srv]: group quotas turned on
/dev/sda3 [/srv]: user quotas turned on

The quotas seem to be ok on /srv but not on /

But after boot I run this commands

mount -o remount /
quotacheck -avugm
quotaon -avug

And I got turn quota On the / partition the messages are:

/dev/sda2 [/]: group quotas turned on
/dev/sda2 [/]: user quotas turned on
/dev/sda3 [/srv]: group quotas device is busy
/dev/sda3 [/srv]: user quotas device is busy


Why?


All times are GMT +2. The time now is 17:21.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.