HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   After accidental file delete - stats not being updated (http://www.howtoforge.com/forums/showthread.php?t=37971)

Been Told 4th August 2009 21:57

After accidental file delete - stats not being updated
 
Hi,
when a webX folder was almost completely deleted, I re-uploaded the contents of the webX/web folder and I thought I only needed to recreate the other folders (only the log folder and the web folder were deleted I think). But now I wanted to check stats and saw, there were none there for that user. Other webX folders are fine and they are keeping track of stats.

So I'm guessing I over-simplified my thinking on this one (i.e. didn't think right lol) - can anyone give me a hint on how to make that webX user start making access logs again so I can get stats with my awstats (which work on other webX users)?

The server is the root server in my signature.

Been Told 4th August 2009 23:52

OK it's getting weirder:
You know how ISPconfig creates symlinks like webX -> www.domain.tld

Now I just saw that the relevant symlink is not a symlink but an actual folder with the name of the domain of user/website webX. There is a huge Apache log file in there, but no log files in webX/log
Also when I go into ISPconfig, open the relevant site, and click the statistics tab: The statistics are all at 0.

till 5th August 2009 09:39

Copy the apache log file to the correct subfolder in webx, then delete the www.domain.tld folder and replace it with a symlink to the webx folder.

Been Told 5th August 2009 10:23

Hi Till, thanks for that!
I've done this - but now I have another problem. I have a stats and an awstats folder in my /var/www/webX/web folder and I have disabled htaccess protection on both.
When I call them in my browser (www.domain.tld/stats or www.domain.tld/awstats) it gives me a 403 error.
Should I just wait for new stats to be added? Or reload apache2 perhaps?

till 5th August 2009 10:26

You will have to wait until the stats get generated tomorrow morning.


All times are GMT +2. The time now is 15:13.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.