HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Lenny Firewall/router/DHCP (http://www.howtoforge.com/forums/showthread.php?t=37873)

shopgeek 31st July 2009 22:39

Lenny Firewall/router/DHCP
 
Goodafternoon,

I am using the tutorial "NAT Gateway, Iptables, Port Forwarding, DNS And DHCP Setup - Ubuntu 8.10 Server" to setup a Lenny box as a firewall/router/DHCP, and, after performing the requested tasks I can:

1. Aquire an IP.
2. ISP provided DNS servers are being forwarded.
3. I can ping any address.
4. I can resolve any address via my browser, but no data is being downloaded. I constantly receive a "Waiting..." status.
5. I can connect to any of my FTP sites, but whenever I attempt an "ls" or "dir", I receive an error stating that it will not transmit data to <172.xxx.xxx.xxx>, my private IP, only to <64.XXX,XXX,XXX>, my public IP.

Any thoughts? The configs are entered exactly as they are detailed in the tutorial, with the exception of different names and local IP addresses.

Thank you,

falko 1st August 2009 10:38

Regarding FTP, did you try both active and passive transfers in your FTP client?

shopgeek 1st August 2009 17:17

Hi Falko,

In passive mode, I would only receive a less descriptive message. :)

sg.

HaydenHarnet 3rd August 2010 19:44

changing transfert to active mode has solved the problem for me

Quote:

Originally Posted by shopgeek (Post 199835)
Goodafternoon,

I am using the tutorial "NAT Gateway, Iptables, Port Forwarding, DNS And DHCP Setup - Ubuntu 8.10 Server" to setup a Lenny box as a firewall/router/DHCP(Nfiniti Router ), and, after performing the requested tasks I can:

1. Aquire an IP.
2. ISP provided DNS servers are being forwarded.
3. I can ping any address.
4. I can resolve any address via my browser, but no data is being downloaded. I constantly receive a "Waiting..." status.
5. I can connect to any of my FTP sites, but whenever I attempt an "ls" or "dir", I receive an error stating that it will not transmit data to <172.xxx.xxx.xxx>, my private IP, only to <64.XXX,XXX,XXX>, my public IP.

Any thoughts? The configs are entered exactly as they are detailed in the tutorial, with the exception of different names and local IP addresses.

Thank you,



All times are GMT +2. The time now is 01:41.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.