HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Own Error Documents not displaying (http://www.howtoforge.com/forums/showthread.php?t=37818)

Cracklefish 29th July 2009 14:58

Own Error Documents not displaying
 
The Error Docs on all sites on the server do not display.
"Own Error Docs" is checked for each site (and saved).

The Vhost files all have a set of errordoc statements
eg.
Code:

ErrorDocument 400 /error/400.html
The site error log shows:

Code:

[Wed Jul 29 13:15:23 2009] [error] [client 82.70.171.142] File does not exist: /srv/www/news-source.co.uk/web/images.htm
[Wed Jul 29 13:15:23 2009] [error] [client 82.70.171.142] File does not exist: /usr/share/apache2/error/404.html

If "Own Error Docs" is unchecked then the common error docs function correctly.

ISPconfig 3.0.1.3 & OpenSuse 11.1

mghens 17th September 2009 04:41

Thanks, having the same issue.

till 17th September 2009 11:25

Please enable the error docs, wait a minute and then check the vhost file for the website if the custom error docs arecproperly listed there.

mghens 26th September 2009 18:29

I think the problem is that my error docs are of the form:

fileNotFound.html

where the apache server is looking for:

ErrorDocument 404 /error/404.html

Cracklefish 1st October 2009 19:37

Hi Till,

Own error docs are enabled, the vhost entries are correct and the files are present in the error folder.

If I try to access dummy.htm

the access log gives:

Code:

82.70.171.142 - - [01/Oct/2009:17:23:53 +0100] "GET /dummy.htm HTTP/1.1" 404 0 "-" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)"
There is no entry in the error log.

I have upgraded to 3.0.1.4 since my original post but no change.

till 1st October 2009 20:06

Please make sure that you looked into the correct error log. Every site has its own error log file in its log folder.

Cracklefish 2nd October 2009 12:05

Quote:

Originally Posted by till (Post 206284)
Please make sure that you looked into the correct error log. Every site has its own error log file in its log folder.

Silly me! Sorry.

The error log entries are:

Code:

[Thu Oct 01 17:23:53 2009] [error] [client 82.70.171.142] File does not exist: /srv/www/greenway.co.uk/web/dummy.htm
[Thu Oct 01 17:23:53 2009] [error] [client 82.70.171.142] File does not exist: /usr/share/apache2/error/404.html


till 2nd October 2009 12:26

Please go trough your apache2.conf file or httpd.conf file, there must be a alias for the /error/ directory pointing to /usr/share/apache2/error. Comment out this alias and restart apache.

Cracklefish 2nd October 2009 13:16

Quote:

Originally Posted by till (Post 206315)
Please go trough your apache2.conf file or httpd.conf file, there must be a alias for the /error/ directory pointing to /usr/share/apache2/error. Comment out this alias and restart apache.



There was a line:

Code:

Include /etc/apache2/errors.conf
in httpd.conf

Now all is wonderful, thank you.


All times are GMT +2. The time now is 12:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.