HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   [debian] Freeradius with MySQL and daloradius ? (http://www.howtoforge.com/forums/showthread.php?t=37691)

GHz 23rd July 2009 21:01

[debian] Freeradius with MySQL and daloradius ?
 
Hi all,

I saw this howto: Setting Up A FreeRadius Based AAA Server With MySQL & Management With Daloradius . This howto however, is for Ubuntu. I'm looking for this howto but then for Debian 5.0. Could someone please explain to me what I need to do to make it work on Debian?

Thanks!

awan 24th July 2009 09:17

Yes its shouldnt be a problem as ubuntu is based on the debianīs testing version, I think its SID these days.
go ahead try it and cough up a nice howto .
--
Ozzy

GHz 24th July 2009 15:20

Getting stuck when wanting to issue this command: 'dpkg-buildpackage -rfakeroot', it returns errors. I tried apt-get install fakeroot, but that didnt solve it. Any ideas?

falko 25th July 2009 09:18

What are the exact error messages?

GHz 28th July 2009 13:36

The first strange thing is, that my source package contains this:

Quote:

freeradius-2.0.4+dfsg freeradius_2.0.4+dfsg-6.dsc
freeradius_2.0.4+dfsg-6.diff.gz freeradius_2.0.4+dfsg.orig.tar.gz
Which one do I need?

If I choose freeradius-2.0.4+dfsg and I run vi debian/rules my for-loop looks also different:

Quote:

dh_makeshlibs -a -n
for pkg in ${pkgs} ; do \
if dh_shlibdeps -p $$pkg -- -O 2>/dev/null | grep -q libssl; then \
echo "$$pkg links to openssl" ;\
exit 1 ;\
fi ;\
done
Is this the for-loop they talk about?

awan 28th July 2009 13:42

U need all of those packages. Check out the link that I had pasted (regarding compiling..some debian link I think. in reference i.e.). Itīll develop the concept.
Cheers
---
Ozzy

GHz 28th July 2009 13:50

I continued compiling but again I get an error, but I am sure I have all the packages (using apt-get), also python-dev and ilbssl.

Quote:

dpkg-buildpackage: warning: using a gain-root-command while being root
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value:
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package freeradius
dpkg-buildpackage: source version 2.0.4+dfsg-6
dpkg-buildpackage: source changed by Stephen Gran <sgran@debian.org>
dpkg-buildpackage: host architecture i386
dpkg-checkbuilddeps: warning: can't parse dependency python-dev libssl-dev
dpkg-checkbuilddeps: error: error occurred while parsing Build-Depends/Build-Dep ends-Indep)
dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: warning: (Use -d flag to override.)

With the howto at the end of the howto that I followed it returns the same errors...

Edit: I also don't have an example scheme for MYSQL in the freeradius package...

awan 30th July 2009 07:04

1 Attachment(s)
U need libssl-dev not just libssl.
As for mysql check out the attached schema
Cheers
---
Ozzy

GHz 30th July 2009 12:06

Thanks for the information about the schemes, I imported the SQL one, but again, I ran into some problems. In my radiusd.conf, there is no authorize section and also no accounting section, so I just pasted them under the last section. When I start freeradius in debugmode, it returns the following:

Quote:

/etc/freeradius/radiusd.conf[750]: Failed to find module "sql".
/etc/freeradius/radiusd.conf[744]: Errors parsing authorize section.
Errors initializing modules
What can be done to solve this?

falko 4th August 2009 13:40

Is there maybe a freeradius-mysql package that needs to be installed?


All times are GMT +2. The time now is 14:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.